Bug 1146228 - Metric detail hover is missing from graphs
Summary: Metric detail hover is missing from graphs
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: UI
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ER05
: JON 3.3.0
Assignee: Jirka Kremser
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-24 20:01 UTC by Larry O'Leary
Modified: 2014-12-11 14:02 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-12-11 14:02:01 UTC


Attachments (Terms of Use)
metrics_mouse-hoverff31 (159.43 KB, image/png)
2014-10-24 12:27 UTC, Armine Hovsepyan
no flags Details
metrics-hover_chrome (153.68 KB, image/png)
2014-10-24 12:27 UTC, Armine Hovsepyan
no flags Details
metrics-hover-ff18 (171.99 KB, image/png)
2014-10-24 12:28 UTC, Armine Hovsepyan
no flags Details

Description Larry O'Leary 2014-09-24 20:01:43 UTC
Description of problem:
When viewing metric graph on metrics monitoring page, the pop-up or hover containing the metric collection details is not visible.

Version-Release number of selected component (if applicable):
3.3.0.ER03 (4aefe39:44e33a4)

How reproducible:
Always

Steps to Reproduce:
1. Start JBoss ON system.
2. Wait for metrics to be collected for any resource.
3. View a metric graph that contains bars to indicate metrics have been collected.
4. Hover the mouse over the bar.

Actual results:
No hover/pop-up.

Expected results:
Hover/pop-up displaying the metric details:
Start: <TIME>
Date: <DATE>
Value: <METRIC VALUE>

Additional info:
I only have Firefox 32.0 available for testing so am not sure if this also occurs in other browsers and browser versions. I have confirmed that using a 3.2.3 server, the hover displays just fine. Therefore, this appears to be a regression introduced somewhere in 3.3.

Comment 1 Jay Shaughnessy 2014-09-24 20:12:18 UTC
Comments from Mike:

(4:07:02 PM) mtho11: must be a z layer thing introduced by the patternfly css
(4:07:14 PM) mtho11: it was working before that
(4:07:32 PM) mtho11: and no changes have been made to that stuff

Comment 2 Simeon Pinder 2014-09-29 08:12:54 UTC
Moving into ER05 as didn't make the ER04 cut.

Comment 3 Jirka Kremser 2014-10-01 14:42:09 UTC
branch:  master
link:    https://github.com/rhq-project/rhq/commit/ff40ccfca
time:    2014-10-01 16:41:17 +0200
commit:  ff40ccfcac0ccabcf626f58c02ffb62476b6ea7f
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 1146228] - Metric detail hover is missing from graphs - this was
         caused by "! important" in style definition in patternfly.css
         because it overrided the elements style attribute (where we
         programatically set if the hover is shown of hidden). I've
         created a new css style called rhqHidden where the "!
         important" is not used.

Comment 4 Libor Zoubek 2014-10-08 09:56:10 UTC
branch:  release/jon3.3.x
link:    https://github.com/rhq-project/rhq/commit/ff88d7e26
time:    2014-10-08 11:55:33 +0200
commit:  ff88d7e268f539862f0297b534993ad0eff13a8f
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 1146228] - Metric detail hover is missing from graphs - this was
         caused by "! important" in style definition in patternfly.css
         because it overrided the elements style attribute (where we
         programatically set if the hover is shown of hidden). I've
         created a new css style called rhqHidden where the "!
         important" is not used.
         (cherry picked from commit
         ff40ccfcac0ccabcf626f58c02ffb62476b6ea7f) Signed-off-by: Libor
         Zoubek <lzoubek@redhat.com>
         Conflicts:
         modules/enterprise/gui/coregui/src/main/webapp/org.rhq.coregui.CoreGUI/sc/skins/CoreGUI/skin_styles.css

Comment 6 Simeon Pinder 2014-10-21 20:24:35 UTC
Moving to ON_QA as available to test with the latest brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=394734

Comment 7 Armine Hovsepyan 2014-10-24 12:27:22 UTC
Created attachment 950375 [details]
metrics_mouse-hoverff31

Comment 8 Armine Hovsepyan 2014-10-24 12:27:58 UTC
Created attachment 950377 [details]
metrics-hover_chrome

Comment 9 Armine Hovsepyan 2014-10-24 12:28:24 UTC
Created attachment 950378 [details]
metrics-hover-ff18

Comment 10 Armine Hovsepyan 2014-10-24 12:28:59 UTC
verified in JON 3.3 ER05 FF18, FF31, Chrome -- screen-shots attached


Note You need to log in before you can comment on or make changes to this bug.