Bug 114624 - segfault when using php recomplied for oracle 9
segfault when using php recomplied for oracle 9
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: php (Show other bugs)
3.0
All Linux
low Severity low
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks: 107563
  Show dependency treegraph
 
Reported: 2004-01-30 06:58 EST by Pierre Amadio
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-11 23:22:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre Amadio 2004-01-30 06:58:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
When recompiling php for RHEL3 in order to have the oracle support,
apache segfault on starting.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.recompile php-4.3.2-ent with  rpmbuild  --rebuild  --define 'oracle
1' php-4.3.2-8.ent.src.rpm 

2. install it and restart apache
    

Actual Results:  apache segfault

Expected Results:  apache does not segfault

Additional info:

There seems to be a similar bug on php.net's php:

http://bugs.php.net/bug.php?id=23733
Comment 3 Joe Orton 2004-04-23 05:49:26 EDT
Fix included in the php-4.3.2-11.ent package in the U2 beta.
Comment 4 Stephen Lawrence Jr. 2004-04-30 18:05:01 EDT
I am having issues with sefault on oci8 applications, but apache seems
to startup fine. From what I have found, it is SHARED issue. 

I will rebuild 4.3.2-11 rpm and install it and see if that fixes my
problem as well.
Comment 5 Stephen Lawrence Jr. 2004-04-30 18:08:32 EDT
Another NOTE:

Here is my exact problem. Does this bug fix take care of this issue?

http://www.zend.com/lists/php-dev/200307/msg00227.html
Comment 6 John Flanagan 2004-05-11 23:22:43 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-169.html

Note You need to log in before you can comment on or make changes to this bug.