Bug 1146252 - rubygem-staypuft: Selecting hosts with different interfaces in the "Configure Networks" prompts "<hostname> does not have interfaces with same names", Exiting from that error messes up the UI.
Summary: rubygem-staypuft: Selecting hosts with different interfaces in the "Configur...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: z2
: Installer
Assignee: Jason E. Rist
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-24 20:54 UTC by Alexander Chuzhoy
Modified: 2014-11-04 17:02 UTC (History)
6 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.4.7-1.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-04 17:02:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description Alexander Chuzhoy 2014-09-24 20:54:40 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Alexander Chuzhoy 2014-09-24 21:00:32 UTC
rubygem-staypuft:  Selecting hosts with different interfaces in the "Configure Networks" prompts  "<hostname> does not have interfaces with same names", Exiting from that error messes up the UI.


Environment:
rhel-osp-installer-0.3.6-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-foreman-installer-2.0.26-1.el6ost.noarch
openstack-puppet-modules-2014.1-21.8.el6ost.noarch

Steps to reproduce:
1. Run rhel-osp-installer
2. Create a deployment of any type.
3. Assign hosts to deployment.
4. Go to the host tab of the deployment and click on free.
5. Select hosts with at least one different NIC and click on the "configure network" button.
6. You should get an error: <hostname> does not have interfaces with same names
7. Close that error
Result:
The UI becomes messed up. You'll see doubles of the top menu. If you redo steps 5-7, the mess will get worse and the UI will also get stuck for some time.

Expected result:
The UI shouldn't get messed up/stuck when hosts with different NICs are selected.

Comment 3 Jason E. Rist 2014-10-07 16:03:31 UTC
https://github.com/theforeman/staypuft/pull/327

Comment 4 Jason E. Rist 2014-10-07 16:20:11 UTC
Merged upstream

Comment 7 Alexander Chuzhoy 2014-10-14 17:14:39 UTC
The error isn't thrown now at all, allowing to configure networks for hosts with different NICs, which is wrong.

Comment 8 Alexander Chuzhoy 2014-10-14 18:14:14 UTC
Verification: FailedQA

Environment:
rhel-osp-installer-0.4.2-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-puppet-modules-2014.1-23.el6ost.noarch
openstack-foreman-installer-2.0.29-1.el6ost.noarch


The error isn't thrown now at all, allowing to configure networks for hosts with different NICs, which is wrong.

Comment 9 Scott Seago 2014-10-15 13:44:41 UTC
Can you verify that the error is still thrown if the assignments for the nics are different -- or whether that one is also failing to trigger? Basically take 2 hosts with the same network config, assign nics on one of them, and then attempt to assign nics to both. If this is working correctly, you should get an error message saying that the hosts have differing nic assignments.

Comment 12 Alexander Chuzhoy 2014-10-21 23:01:12 UTC
Verified: FailedQA
Environment:
openstack-puppet-modules-2014.1-24.el6ost.noarch
rhel-osp-installer-0.4.5-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-foreman-installer-2.0.30-1.el6ost.noarch
ruby193-rubygem-staypuft-0.4.8-1.el6ost.noarch


What happens now is as following:
The following error is shown to the user:
<hostname>: does not have interfaces with same names

And then the user is redirected to the overview page of the deployment.



1. No redirection should occur. 
2. There are at least 2 hosts selected, perhaps its better just to mention that the selected hosts don't have all interfaces with same names.

Comment 13 Mike Burns 2014-10-22 00:26:57 UTC
This bug was filed because the UI would get messed up when the error was closed.  Based on the comments, the UI does not get get messed up anymore.  

Other issues, such as improving the message or redirection should be filed separately as new issues

Comment 14 Alexander Chuzhoy 2014-10-22 14:30:37 UTC
Verified:
openstack-puppet-modules-2014.1-24.el6ost.noarch
rhel-osp-installer-0.4.5-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-foreman-installer-2.0.30-1.el6ost.noarch
ruby193-rubygem-staypuft-0.4.8-1.el6ost.noarch

The reported issue doesn't reproduce.
Based on comments #12 and #13 resolving the bug.
The issue from comment #12 is reported in BZ #1155646.

Comment 16 errata-xmlrpc 2014-11-04 17:02:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.