Bug 1146277 - virt-manager can lose track of VM state
Summary: virt-manager can lose track of VM state
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1158408 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-24 22:30 UTC by Cole Robinson
Modified: 2015-09-24 20:17 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-24 20:17:49 UTC


Attachments (Terms of Use)
virt-manager --debug output on F20 (32.30 KB, text/plain)
2015-03-30 17:50 UTC, Oliver Henshaw
no flags Details

Description Cole Robinson 2014-09-24 22:30:46 UTC
Not sure how exactly it happened, but virt-manager lost track of one of my VMs run state. It was permanently stuck as 'Running' in the manager window, regardless of whether I started or stopped it with virsh.

When it was off, if I tried to 'stop' it in the UI, it would rightly error (from libvirt) that the VM was already shut off, but the UI didn't update.

In the debug output, I could see that libvirt was delivering the start/stop signals and virt-manager was logging a bit, but it didn't seem to make a difference updating the manager window at least.

Comment 1 M. Edward (Ed) Borasky 2014-09-25 05:42:25 UTC
I've seen this twice tonight during installs to fresh VMs. The first one was with an OSGeo Live (Lubuntu 14.04) guest and the second with a Fedora 20 guest. The symptom was the same in both cases - go through the standard install procedure and initiate a shutdown inside the guest. It shuts down, the console goes blank but Virtual Machine Manager shows the guest as still running. Restarting Virtual Machine Manager gives the correct state of the guest.

Comment 2 Mike Ruckman 2014-09-25 23:18:53 UTC
I've seen this intermittently in as well.

Comment 3 M. Edward (Ed) Borasky 2014-09-26 04:18:28 UTC
Is there some kind of logging either already in place or something we can enable? It seemed pretty reproducible to me - it happened twice. If we had logging I could go through my standard install sequence until it happened.

Comment 4 Cole Robinson 2014-10-29 17:57:12 UTC
*** Bug 1158408 has been marked as a duplicate of this bug. ***

Comment 5 Oliver Henshaw 2015-03-30 17:50:01 UTC
Created attachment 1008626 [details]
virt-manager --debug output on F20

I see this on F20 with a qemu://session connection. I seem to be able to reproduce it just after 'installing' a live iso image (not to disk, just so I can boot the iso in a VM)

In the attached debug output, I installed the live iso (Choosing to install an existing disk image and selecting the F21 Workstation iso - I also had to delete the qemu-ga channel to workaround bug #1105274) Then the VM was shut off from the gnome top-right menu: the "Viewer disconnected" line came when the vm finished shutting off. Then you can see I closed the VM details window and saw the main virt-manager window reported that it was still running. I reopened the VM details window and it told me it was not running, but the main window still didn't realise this.

Then I close virt-manager, waited for the qemu://session libvirtd to time out and re-opened it and it no longer reported that the VM was running. I I repeated the boot and shutdown cycle and this time virt-manager reported it was no longer running.


Packages installed:

virt-manager-1.0.1-5.fc20.noarch
libvirt-1.1.3.9-1.fc20.x86_64

Comment 6 Raphael Groner 2015-08-28 13:00:03 UTC
I could reproduce with F21 host, but never notice that with a F22 host.

Comment 7 Cole Robinson 2015-09-24 20:17:49 UTC
I haven't seen this on f22 and later either... so since the root issue was never found it's unlikely to be fixed on f21. So just closing this as CURRENTRELEASE for f22


Note You need to log in before you can comment on or make changes to this bug.