Bug 1146281 - Compilation on OSX is broken with upstream git master and release-3.6 branches
Summary: Compilation on OSX is broken with upstream git master and release-3.6 branches
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: GlusterFS
Classification: Community
Component: build
Version: 3.6.0
Hardware: Unspecified
OS: Mac OS
high
urgent
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1146279
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-24 22:40 UTC by Justin Clift
Modified: 2016-06-28 15:02 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1146279
Environment:
Last Closed: 2016-06-28 15:02:23 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Justin Clift 2014-09-24 22:40:00 UTC
+++ This bug was initially created as a clone of Bug #1146279 +++

Description of problem:

  Just tried compiling git master and release-3.6 branches on OSX 10.7.5, but the compile breaks on both (with same error):

********************************************************************
Making all in src
  CC       glusterd_la-glusterd.lo
  CC       glusterd_la-glusterd-handler.lo
  CC       glusterd_la-glusterd-sm.lo
  CC       glusterd_la-glusterd-op-sm.lo
  CC       glusterd_la-glusterd-utils.lo
  CC       glusterd_la-glusterd-rpc-ops.lo
  CC       glusterd_la-glusterd-store.lo
  CC       glusterd_la-glusterd-handshake.lo
  CC       glusterd_la-glusterd-pmap.lo
  CC       glusterd_la-glusterd-volgen.lo
  CC       glusterd_la-glusterd-rebalance.lo
  CC       glusterd_la-glusterd-quota.lo
  CC       glusterd_la-glusterd-geo-rep.lo
glusterd-quota.c:238:51: error: use of undeclared identifier '_PATH_SETFATTR'
                                         "-exec", _PATH_SETFATTR, "-n",
                                                  ^
1 error generated.
make[5]: *** [glusterd_la-glusterd-quota.lo] Error 1
make[5]: *** Waiting for unfinished jobs....
make[4]: *** [all-recursive] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
==> Configuration
HOMEBREW_VERSION: 0.9.5
HEAD: 93793774cf89823cc1e1ff411dc2063a7556f254
CPU: 8-core 64-bit sandybridge
OS X: 10.7.5-x86_64
Xcode: 4.6.3
CLT: 1.0.0.9000000000.1.1249367152
X11: 2.6.5 => /usr/X11
==> ENV
HOMEBREW_CC: clang
HOMEBREW_CXX: clang++
MAKEFLAGS: -j8
CMAKE_PREFIX_PATH: /usr/local/opt/gettext:/usr/local/opt/libxml2:/usr/local/opt/openssl:/usr/local/opt/readline:/usr/local/opt/sqlite:/usr/local
CMAKE_INCLUDE_PATH: /System/Library/Frameworks/OpenGL.framework/Versions/Current/Headers
CMAKE_LIBRARY_PATH: /System/Library/Frameworks/OpenGL.framework/Versions/Current/Libraries
CMAKE_FRAMEWORK_PATH: /usr/local/opt/python/Frameworks
PKG_CONFIG_PATH: /usr/local/opt/cmockery2/lib/pkgconfig:/usr/local/opt/libxml2/lib/pkgconfig:/usr/local/opt/openssl/lib/pkgconfig:/usr/local/opt/osxfuse/lib/pkgconfig:/usr/local/opt/sqlite/lib/pkgconfig
PKG_CONFIG_LIBDIR: /usr/lib/pkgconfig
ACLOCAL_PATH: /usr/local/opt/gettext/share/aclocal:/usr/local/opt/libxml2/share/aclocal:/usr/local/share/aclocal
PATH: /usr/local/Library/ENV/4.3:/usr/local/opt/autoconf/bin:/usr/local/opt/automake/bin:/usr/local/opt/libtool/bin:/usr/local/opt/gettext/bin:/usr/local/opt/libxml2/bin:/usr/local/opt/openssl/bin:/usr/local/opt/pkg-config/bin:/usr/local/opt/sqlite/bin:/usr/local/opt/gdbm/bin:/usr/local/opt/python/bin:/usr/bin:/bin:/usr/sbin:/sbin

********************************************************************

  Harsha says it's a problem introduced after recent NetBSD fixes.


Version-Release number of selected component (if applicable):

  git master and release-3.6 branches as of Wed 24th Sept 2014

Comment 2 Mike McCune 2016-03-28 22:22:31 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 3 Soumya Koduri 2016-04-19 12:48:20 UTC
Bug query complains that
** bugs@gluster.org: No change posted, but bug 1146281 is in POST **

Could you please correct the same. Thanks!

Comment 4 Niels de Vos 2016-06-28 15:02:23 UTC
http://review.gluster.org/8841 needs to get backported to the release-3.6 branch in order to fix this. I'm not sure how many users want to run glusterfs-3.6.x on Mac OSX. Nobody except Justin seems to have complained about it, and he was testing the build. glusterfs-3.7.0 should have addressed this problem.

Closing WONTFIX, unless someone really needs this.


Note You need to log in before you can comment on or make changes to this bug.