Bug 1146297 - error hotplugging USB device: 'vmmDomain' object has no attribute 'name'
Summary: error hotplugging USB device: 'vmmDomain' object has no attribute 'name'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1159551 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-25 00:05 UTC by Cole Robinson
Modified: 2014-11-22 00:46 UTC (History)
4 users (show)

Fixed In Version: virt-manager-1.1.0-4.git310f6527.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-22 00:46:32 UTC


Attachments (Terms of Use)
addhardware-Fix-attaching-USB-PCI-hostdev-bz-1146297 (1.01 KB, patch)
2014-11-18 17:58 UTC, Gene Czarcinski
no flags Details | Diff

Description Cole Robinson 2014-09-25 00:05:41 UTC
UI error trying to hotplug VM USB device:

[Wed, 24 Sep 2014 19:59:42 virt-manager 2897] ERROR (error:122) Validation Error: Host device parameter error 'vmmDomain' object has no attribute 'name'
Traceback (most recent call last):
  File "/home/crobinso/src/virt-manager/virtManager/addhardware.py", line 1747, in validate_page_hostdev
    names.append(vm.name)
AttributeError: 'vmmDomain' object has no attribute 'name'

Comment 1 Cole Robinson 2014-09-25 00:13:25 UTC
Fixed upstream now:

commit 3e5a20aaf13b97b2afe4415d3557dae74f89eaf7
Author: Cole Robinson <crobinso@redhat.com>
Date:   Wed Sep 24 20:12:38 2014 -0400

    addhardware: Fix attaching USB/PCI hostdev (bz 1146297)

Comment 2 Gene Czarcinski 2014-11-10 01:34:02 UTC
Would be nice if this was incorportated sooner rahtert than later.  Having problems trying to use some (not all) host usb-stick drived for booting.

Applied the fix (rebuilt with mock) and things now work.

See my recent posting to the kickstart mailing list.

Comment 3 Cole Robinson 2014-11-15 17:53:55 UTC
*** Bug 1159551 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2014-11-16 20:10:50 UTC
virt-manager-1.1.0-4.git310f6527.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/virt-manager-1.1.0-4.git310f6527.fc21

Comment 5 Fedora Update System 2014-11-18 12:13:54 UTC
Package virt-manager-1.1.0-4.git310f6527.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing virt-manager-1.1.0-4.git310f6527.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-15270/virt-manager-1.1.0-4.git310f6527.fc21
then log in and leave karma (feedback).

Comment 6 Gene Czarcinski 2014-11-18 17:57:03 UTC
Sorry, NOT a winner!  As comment#1 says, you need the cited patch and that is NOT in 1.1.0-4-git310f6527

Just to make sure we are all marching to the same music, I am attaching the patch.  With this patch applied to 1.1.0-4-git310f6527 the problem is fixed.

Comment 7 Gene Czarcinski 2014-11-18 17:58:07 UTC
Created attachment 958685 [details]
addhardware-Fix-attaching-USB-PCI-hostdev-bz-1146297

Comment 8 Gene Czarcinski 2014-11-18 18:12:58 UTC
Me bad!  I got the src.rpm from fc21 and sure enough, the right patch is included.

Comment 9 Fedora Update System 2014-11-22 00:46:32 UTC
virt-manager-1.1.0-4.git310f6527.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.