Bug 1146463 - Staypuft related JS modification doesn't load on hosts#edit
Summary: Staypuft related JS modification doesn't load on hosts#edit
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: z2
: Installer
Assignee: Imre Farkas
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On: 1144649
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-25 09:58 UTC by Imre Farkas
Modified: 2016-09-20 05:03 UTC (History)
10 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.4.2-1.el6ost
Doc Type: Bug Fix
Doc Text:
Prior to this update, method used to override Red Hat Enterprise Linux OpenStack Platform installer views behaved differently in development and production environments. As a result, an additional javascript file which enhanced the fencing tab on the hosts#edit form was missing in the production environment. This update addresses this issue by changing the override rule. As a result, the javascript file is correctly included in the installer view.
Clone Of: 1144649
Environment:
Last Closed: 2014-11-04 17:02:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description Imre Farkas 2014-09-25 09:58:22 UTC
+++ This bug was initially created as a clone of Bug #1144649 +++

Description of problem:
staypuft/hosts_edit.js doesn't load on hosts#edit

Version-Release number of selected component (if applicable):
0.3.9

How reproducible:
Always

Steps to Reproduce:
1. Go to the edit view on the host
2. Check the source of the page

Actual results:
staypuft/hosts_edit.js is not referenced in the html page, so the js file is not loaded.

Expected results:
staypuft/hosts_edit.js should be referenced on hosts#edit page

Comment 3 Mike Burns 2014-09-25 13:09:15 UTC
moving to A2 target.

Comment 4 Imre Farkas 2014-09-30 11:15:03 UTC
PR: https://github.com/theforeman/staypuft/pull/319

Comment 8 Alexander Chuzhoy 2014-10-14 17:48:48 UTC
Verification: Failed-qa
hosts_edit.js isn't referenced when viewing the page source trying to edit a host.


Environment:
rhel-osp-installer-0.4.2-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-puppet-modules-2014.1-23.el6ost.noarch
openstack-foreman-installer-2.0.29-1.el6ost.noarch

Comment 9 Alexander Chuzhoy 2014-10-15 19:46:32 UTC
Verified:
rhel-osp-installer-0.4.4-1.el6ost.noarch
openstack-puppet-modules-2014.1-24.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-foreman-installer-2.0.30-1.el6ost.noarch



The line staypuft/host_edit<-hash string>.js is there.

Comment 11 errata-xmlrpc 2014-11-04 17:02:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.