Bug 114647 - qt-3.2.3 mouse patch
qt-3.2.3 mouse patch
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: qt (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-30 12:49 EST by Sammy
Modified: 2007-04-18 13:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-30 15:19:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (1.36 KB, patch)
2004-01-30 12:50 EST, Sammy
no flags Details | Diff

  None (edit)
Description Sammy 2004-01-30 12:49:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux; X11; , en_US, en)

Description of problem:
Since the upgrade to qt-3.2.3 some of my users started to experience
mouse lockings when using the konqueror file manager. The problem
was that when the left mouse button was pressed it remained pressed
when the mouse was moved to the other pane. The mouse sometimes
worked ok for  a while after a restart of X. I now that this was a problem
fixed from 3.2.0 to 3.2.1 or 3.2.2 but somehow creeped back in 3.2.3.

Anyway, I found a patch from the Mandrake rpm that fixes this problem.
I am attaching the patch.

Thanks

Version-Release number of selected component (if applicable):
qt-3.2.3-0.2

How reproducible:
Sometimes

Steps to Reproduce:
1. start konqueror file manager
2. go to the file-tree pane and click onto a directory containing fjles
3. move the mouse (after releasing the left button) to the file pane -- sticks
    

Additional info:
Comment 1 Sammy 2004-01-30 12:50:14 EST
Created attachment 97370 [details]
patch
Comment 2 Ngo Than 2004-01-30 15:19:33 EST
it's fixed in qt-3.2.3-0.4. thanks for your bug report.

Note You need to log in before you can comment on or make changes to this bug.