Bug 114649 - debug-panel.xsl doesn't work on Xalan
debug-panel.xsl doesn't work on Xalan
Status: CLOSED WONTFIX
Product: Red Hat Web Application Framework
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity low
: ---
: ---
Assigned To: ccm-bugs-list
Jon Orris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-30 13:02 EST by Vadim Nasardinov
Modified: 2007-04-18 13:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-03 14:44:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshots (102.30 KB, image/png)
2004-01-30 13:03 EST, Vadim Nasardinov
no flags Details

  None (edit)
Description Vadim Nasardinov 2004-01-30 13:02:05 EST
//core-platform/dev/web/packages/ui/xsl/debug-panel.xsl has code that
generates a pretty-printed XML representation of the bebop page, as
well as the page layout structure, when the developer appends
"&transform=debug" to the URL.  To show the structure visually, the
HTML for the pretty-printed representation is placed inside
<pre></pre> tags and uses indentation to convey the tree structure.

The stuff that goes inside the <pre> tag runs with no new lines
whatsoever, when Xalan is used.  It works fine with Saxon.

Marking as low priority, since we don't use Xalan much (if at all).
Comment 1 Vadim Nasardinov 2004-01-30 13:03:14 EST
Created attachment 97371 [details]
screenshots

The screenshot show two Mozilla windows side by side.  One has
the correct output generated by Saxon, and the other incorrect
by Xalan.
Comment 2 Vadim Nasardinov 2005-08-03 14:44:49 EDT
slate

Note You need to log in before you can comment on or make changes to this bug.