Bug 114652 - Directories not owned by package
Summary: Directories not owned by package
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-XML-Parser   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Chip Turner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-30 18:20 UTC by W. Michael Petullo
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-22 04:27:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description W. Michael Petullo 2004-01-30 18:20:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.6)
Gecko/20040115 Epiphany/1.0.7

Description of problem:
The following directories are not owned by the perl-XML-Parse package:

/usr/lib/perl5/vendor_perl/5.8.0
/usr/lib/perl5/vendor_perl/5.8.0/ppc-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0/ppc-linux-thread-multi/auto
/usr/lib/perl5/vendor_perl/5.8.0/ppc-linux-thread-multi/auto/XML
/usr/lib/perl5/vendor_perl/5.8.0/ppc-linux-thread-multi/auto/XML/Parser/Expat
/usr/lib/perl5/vendor_perl/5.8.0/ppc-linux-thread-multi/XML
/usr/lib/perl5/vendor_perl/5.8.0/ppc-linux-thread-multi/XML/Parser/Encodings

Note that, for example,
/usr/lib/perl5/vendor_perl/5.8.0/ppc-linux-thread-multi/auto/XML/Parser/Expat/Expat.so
is owned by the package.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
[mike@imp mike]$ rpm -qf
/usr/lib/perl5/vendor_perl/5.8.0/ppc-linux-thread-multi/auto/XML
file /usr/lib/perl5/vendor_perl/5.8.0/ppc-linux-thread-multi/auto/XML
is not owned by any package
[mike@imp mike]$ rpm -qf
/usr/lib/perl5/vendor_perl/5.8.0/ppc-linux-thread-multi/auto/XML/Parser/Expat/
file
/usr/lib/perl5/vendor_perl/5.8.0/ppc-linux-thread-multi/auto/XML/Parser/Expat
is not owned by any package
[mike@imp mike]$ rpm -qf
/usr/lib/perl5/vendor_perl/5.8.0/ppc-linux-thread-multi/auto/XML/Parser/Expat/Expat.so
perl-XML-Parser-2.31-16

Additional info:

Comment 1 Warren Togami 2005-03-31 10:29:36 UTC
Please verify is this is still an issue in FC4.  I susspect it isn't due to
changes in rpm and perl.

Comment 2 W. Michael Petullo 2005-03-31 17:26:23 UTC
There still seem to be problems:

These are not owned:

/usr/lib/perl5/vendor_perl/5.8.5/ppc-linux-thread-multi/auto/XML
/usr/lib/perl5/vendor_perl/5.8.5/ppc-linux-thread-multi/auto/XML/Parser/Expat
/usr/lib/perl5/vendor_perl/5.8.5/ppc-linux-thread-multi/XML
/usr/lib/perl5/vendor_perl/5.8.5/ppc-linux-thread-multi/XML/Parser/Encodings
/usr/lib/perl5/vendor_perl/5.8.5/ppc-linux-thread-multi/XML/Parser/Style

even though they contain files that are.

I have perl-XML-Parser-2.34-5 installed now.


Note You need to log in before you can comment on or make changes to this bug.