Bug 114656 - add cc list to "My Bugs" tab
add cc list to "My Bugs" tab
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
David Lawrence
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2004-01-30 14:24 EST by Joel Uckelman
Modified: 2013-06-23 22:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-11-26 11:21:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Joel Uckelman 2004-01-30 14:24:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040116

Description of problem:
I often find myself wanting to see a list of the bugs for which I'm on
the CC: list. Though it's not terribly hard to do a search on the CC:
field of open bugs, it would be nice if the "My Bugs" tab displayed a
list of such bugs.

That way, the "My Bugs" tab would show a complete list of all bugs
that I'm involved with, not just the ones that I reported or have been

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:

Additional info:
Comment 1 Andrew D. Stadler 2004-09-22 13:15:48 EDT
I would like to second the request for cc:.  Here's a specific reason
why:  If I file a bug, and it turns out to be a duplicate, my bug gets
closed and I'm added as a CC on the earlier bug.  *but I'm still very
interested in the results*.  To me, being CC on a bug is just as
important as having filed it originally.

Also, I would like to have "my bugs" expanded to include *all* bugs
I'm involved with, e.g. how about the closed bugs?  resolved
duplicates?  etc.
Comment 2 Alexandre Oliva 2005-03-21 10:01:01 EST
Seconded.  Or rather thirded :-)

I was going to file this request as a bug myself, such that I could keep track
of it in `my bugs'.  But I found it was already filed, so now I can't get it in
`my bugs'.  The same would happen had I actually filed it and then got my bug
marked as a dupe.

Perhaps overloading Cc: with `showing up in My bugs' is imperfect, and we'd be
better off with a separate `Add to my bugs' setting?
Comment 3 David Lawrence 2005-03-21 14:06:46 EST
Or how bout adding another section to the Front Page screen that has bugs that I
am Cc'ed on? Just a question. My Bugs is just a pre-canned query that I can
simple add addition search criteria to that would bring in bugs that have the
bugzilla member on the cc list.
Comment 4 Alexandre Oliva 2005-03-21 14:45:02 EST
That's not quite the same, since it forces people to make a distinction between
bugs they initially filed and other bugs they ran into, got interested in or got
duped into.  Sure enough it's just a minor inconvenience so I could live with
that, but if you replaced, in the pre-canned queries, user = reporter with (user
= reporter or user in cc) (or however you'd spell that in bugzilla's db schema
and query language), that would be fine for me, but I suppose some might prefer
to make the distinction between being Cc:ed and being the original reporter.
Comment 5 Andrew D. Stadler 2005-05-09 18:57:12 EDT
Perhaps we should expand this to request a few things of the old My Bugs (now renamed "My Front 

 - ability to show bugs we are cc'd on
 - ability to show bugs we reported and are assigned to someone else now
 - show a group of bugs that we were involved with but are now CLOSED or RESOLVED
 - I imagine 'developers' (as opposed to those of us who are mainly 'reporters') have a very
    different view of what the front page oughtta look like.  
 - maybe it's time for a very simple set of preferences or a choice between a bug-filer front page or a 
bug-fixer front page....
Comment 6 Alex Lancaster 2005-07-15 06:52:38 EDT
+1 for including a frontpage list of bugs that you are Cc-ed on (i.e
monitoring).  It would save having to create a custom search query.

The could have the same sections (New, In Progress), but with "Monitored Issues"
replacing "Open Issues"

"Monitored Issues: New"
You are monitoring the bug reported by somebody else but nobody has accepted it yet.

"Monitored Issues: In Progress"
You are monitoring a bug reported by somebody else, the developer accepted the
bug and is hopefully working on it.


Comment 7 David Lawrence 2006-04-08 13:44:57 EDT
Red Hat's current Bugzilla version is 2.18. I am moving all older open bugs to
this version. Any bugs against the older versions will need to be verified that
they are still bugs. This will help me also to sort them better.
Comment 8 Alex Lancaster 2006-04-08 19:24:50 EDT
(In reply to comment #7)
> Red Hat's current Bugzilla version is 2.18. I am moving all older open bugs to
> this version. Any bugs against the older versions will need to be verified that
> they are still bugs. This will help me also to sort them better.

This bug/enhancement request is still present.
Comment 9 Joel Uckelman 2007-12-04 06:57:10 EST
Why is this bug set to "NEEDINFO"? What info is needed from me?
Comment 10 David Lawrence 2008-08-04 17:15:03 EDT
Clearing needinfo? flag.
Comment 11 David Lawrence 2008-08-18 17:50:58 EDT
Will investigate implementing this into the 3.2 frontpage.cgi.
Comment 12 Alex Lancaster 2008-11-26 11:21:53 EST
It appears that https://bugzilla.redhat.com/frontpage.cgi now includes a list of bugs that you are Cc'ed on, which is great! So closing this bug.
Comment 13 Joel Uckelman 2008-11-26 12:19:38 EST
Hooray! Thanks.

Note You need to log in before you can comment on or make changes to this bug.