Bug 1146569 - Unable to install RHEV-M 3.5 on RHEL 7 because of JBOSS 6.x repo
Summary: Unable to install RHEV-M 3.5 on RHEL 7 because of JBOSS 6.x repo
Keywords:
Status: CLOSED DUPLICATE of bug 920126
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Sandro Bonazzola
QA Contact: Pavel Stehlik
URL:
Whiteboard: integration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-25 14:11 UTC by Bill Sanford
Modified: 2014-09-25 14:19 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-25 14:19:13 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Bill Sanford 2014-09-25 14:11:21 UTC
Description of problem:
In https://mojo.redhat.com/docs/DOC-970923, I have the latest RHEV-M 3.5 repo, RHEL 7 repos and the "[JBoss_latest]" repo on the main page using JBEAP-6/6.3.1/composes/JBEAP-6.3.1-RHEL-6/Server/x86_64/os/ and not a RHEL 7 JBOSS repo and the dependencies are all FUBAR.

I was expecting to see something like this for RHEL 7 JBOSS repo:
http://download.lab.bos.redhat.com/devel/candidates/JBEAP/JBEAP-6.3.1/composes/JBEAP-6.3.1-RHEL-7/Server/x86_64/os/

Version-Release number of selected component (if applicable):


How reproducible:
100% 

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
I believe I need the 

Additional info:

Dependency errors:

--> Finished Dependency Resolution
Error: Package: rhevm-log-collector-3.5.0-1.el6ev.noarch (qa-latest)
           Requires: sos < 3
           Installed: sos-3.0-23.el7.noarch (@anaconda/7.0)
               sos = 3.0-23.el7
Error: Package: ovirt-host-deploy-1.3.0-0.0.4.master.el6ev.noarch (qa-latest)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-16.el7.x86_64 (@anaconda/7.0)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: rhevm-lib-3.5.0-0.13.beta.el6ev.noarch (qa-latest)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-16.el7.x86_64 (@anaconda/7.0)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: python-ply-3.3-7.el6ev.noarch (qa-latest)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-16.el7.x86_64 (@anaconda/7.0)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: rhevm-3.5.0-0.13.beta.el6ev.noarch (qa-latest)
           Requires: fop
Error: Package: rhevm-cli-3.5.0.4-1.el6ev.noarch (qa-latest)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-16.el7.x86_64 (@anaconda/7.0)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: rhevm-iso-uploader-3.5.0-1.el6ev.noarch (qa-latest)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-16.el7.x86_64 (@anaconda/7.0)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: rhevm-backend-3.5.0-0.13.beta.el6ev.noarch (qa-latest)
           Requires: python-cheetah
Error: Package: rhevm-3.5.0-0.13.beta.el6ev.noarch (qa-latest)
           Requires: ws-commons-util
Error: Package: rhevm-log-collector-3.5.0-1.el6ev.noarch (qa-latest)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-16.el7.x86_64 (@anaconda/7.0)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: rhevm-image-uploader-3.5.0-1.el6ev.noarch (qa-latest)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-16.el7.x86_64 (@anaconda/7.0)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: rhevm-setup-plugin-ovirt-engine-common-3.5.0-0.13.beta.el6ev.noarch (qa-latest)
           Requires: cracklib-python
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@rhevm35 ~]#

Comment 1 Sandro Bonazzola 2014-09-25 14:19:13 UTC
Thanks for reporting. We're aware that 3.5 can't be installed on RHEL 7, we've an RFE open for it.
Closing this as duplicate of that RFE.

*** This bug has been marked as a duplicate of bug 920126 ***


Note You need to log in before you can comment on or make changes to this bug.