Bug 1146585 - Missing --size argument for logvol leads to stacktrace
Summary: Missing --size argument for logvol leads to stacktrace
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-25 14:52 UTC by Fabian Deutsch
Modified: 2014-10-17 20:14 UTC (History)
4 users (show)

Fixed In Version: anaconda-21.48.8-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-11 06:53:57 UTC
Type: Bug


Attachments (Terms of Use)
Kickstart used (319 bytes, text/plain)
2014-09-25 14:52 UTC, Fabian Deutsch
no flags Details
Correct ks now (422 bytes, text/plain)
2014-09-25 14:52 UTC, Fabian Deutsch
no flags Details
expanded ks (1.38 KB, text/plain)
2014-09-26 14:02 UTC, Fabian Deutsch
no flags Details
all sorts of logs (298.06 KB, text/plain)
2014-09-26 14:03 UTC, Fabian Deutsch
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1142274 unspecified CLOSED use of --onpart leads to traceback 2020-10-14 00:28:05 UTC
Red Hat Bugzilla 1154190 high CLOSED logvol swap --recommended without --size fails 2020-10-14 00:28:05 UTC

Internal Links: 1142274 1154190

Description Fabian Deutsch 2014-09-25 14:52:28 UTC
Created attachment 941120 [details]
Kickstart used

Description of problem:
It seems that I am missing some valu somewhere, but whatever it is, would be nice if the error could be displayed more human friendly:

Starting installer, one moment...
anaconda 21.48.3-1 for Fedora 21 (pre-release) started.
14:48:01 Not asking for VNC because of an automated install
Starting automated install.......................................................
 ......Exception yum.Errors.RepoError: RepoError() in <bound method YumSqlitePackageSack.__del__ of <yum.sqlitesack.YumSqlitePackageSack object at 0x7fd807a7bd90>>

    ignored
Exception yum.Errors.RepoError: RepoError() in <bound method YumSqlitePackageSack.__del__ of <yum.sqlitesack.YumSqlitePackageSack object at 0x7fd804415390>>
                                                                             ignored


Generating updated storage configuration

An unknown error has occured, look at the /tmp/anaconda-tb* file(s) for more details


===============================================================================
An unknown error has occurred
===============================================================================
anaconda 21.48.3-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 861, in execute
    if not size:
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 755, in execute
    l.execute(storage, ksdata, instClass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1924, in doKickstartStorage
    ksdata.logvol.execute(storage, ksdata, instClass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/spokes/storage.py", line 372, in execute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/hubs/summary.py", line 53, in setup
    spoke.execute()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/__init__.py", line 170, in setup
    should_schedule = obj.setup(self.ENVIRONMENT)
  File "/sbin/anaconda", line 1358, in <module>
    anaconda._intf.setup(ksdata)
UnboundLocalError: local variable 'size' referenced before assignment

What do you want to do now?
1) Report Bug
2) Debug
3) Run shell
4) Quit

Please make your choice from above: 
[anaconda] 1:main* 2:shell  3:log  4:storage-log  5:program-log                 


Version-Release number of selected component (if applicable):
F21

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Fabian Deutsch 2014-09-25 14:52:57 UTC
Created attachment 941121 [details]
Correct ks now

Comment 2 David Shea 2014-09-25 15:30:03 UTC
We can correct the direct cause of the error, but I can't really tell exactly what's going on, because 1) you didn't attach logs, and 2) the kickstart you attached is just a bunch of %includes.

Comment 3 Fabian Deutsch 2014-09-26 14:02:27 UTC
Created attachment 941578 [details]
expanded ks

I'm attaching the logs now. And the correct ks as well.

Comment 4 Fabian Deutsch 2014-09-26 14:03:38 UTC
Created attachment 941579 [details]
all sorts of logs

Comment 5 Fedora Update System 2014-10-01 15:36:07 UTC
anaconda-21.48.8-1.fc21, python-blivet-0.61.3-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/python-blivet-0.61.3-1.fc21,anaconda-21.48.8-1.fc21

Comment 6 Fedora Update System 2014-10-03 04:00:12 UTC
Package anaconda-21.48.8-1.fc21, python-blivet-0.61.3-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-21.48.8-1.fc21 python-blivet-0.61.3-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-11977/python-blivet-0.61.3-1.fc21,anaconda-21.48.8-1.fc21
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2014-10-04 03:22:43 UTC
Package anaconda-21.48.8-1.fc21, python-blivet-0.61.3-1.fc21, pykickstart-1.99.60-2.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-21.48.8-1.fc21 python-blivet-0.61.3-1.fc21 pykickstart-1.99.60-2.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-11977/pykickstart-1.99.60-2.fc21,python-blivet-0.61.3-1.fc21,anaconda-21.48.8-1.fc21
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2014-10-11 06:53:57 UTC
anaconda-21.48.8-1.fc21, python-blivet-0.61.3-1.fc21, pykickstart-1.99.60-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.