Bug 114659 - cannot compile kernel with ACPI support
cannot compile kernel with ACPI support
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-30 14:54 EST by Marco van Leeuwen
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-04 08:31:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marco van Leeuwen 2004-01-30 14:54:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
When trying to recompile the kernel with acpi support, I get a number
of errors, starting with the fact that include/asm/acpi.h is missing.
I tried several routes to resolution, including copying selected stuff
from 'official' (kernel.org) kernels, but did not find a way to make
things work. It seems that an attempt was made
(linux-2.4.21-acpi-update.patch) to include a newer version of acpi in
the 2.4.21 kernel, but the resulting code is fairly incomplete.

By the way, drivers/acpi/Config.in is not properly included in the
arch/i386/config.in script so I had to do that first.

I tried to find patches for the acpi version in the Redhat enterprise
kernel (ACPI_VERSION 20030619), but the acpi website was cleaned up,
so I could not find anything...

In addition, I would like to mention that 'make xconfig' has serious
problems with the crypto options. As far as I can tell, only
CONFIG_CRYPTO is set after 'make xconfig', and all the other options
(e.g. CONFIG_CRYPTO_HMAC) are removed from the .config file, resulting
in compiler errors. 'make menuconfig' and 'make oldconfig' do work,
however.

Version-Release number of selected component (if applicable):
kernel-source-2.4.21-4.EL and kernel-source-2.4.21-9.EL

How reproducible:
Always

Steps to Reproduce:
1. configure acpi support (see remarks above about including
drivers/acpi.Config.in and make xconfig)
2. make dep
3. make bzImage
    

Actual Results:  Error messages, starting with missing include/asm/acpi.h

Expected Results:  Compiled kernel

Additional info:

I did not make any other changes to the kernel configuration.
Comment 2 Arjan van de Ven 2004-02-04 08:31:13 EST
Self compiled kernels are not supported, and we know ACPI isn't going
to work if you change it; the ACPI in the RHEL3 kernel is the ia64
variant (with patches for amd64) and not for x86.
Comment 3 Sergio Monteiro Basto 2004-04-14 07:46:57 EDT
./acpi/acconfig.h
#define ACPI_CA_VERSION                 0x20030619

ok but We have 2 bugs 
1- /proc/acpi doesn't appears on kernel-source-2.4.21-9.EL but
/boot/config-2.4.21-9.0.1.ELsmp indicates that acpi is compiled and
modules like
CONFIG_ACPI_AC=m
CONFIG_ACPI_BATTERY=m
CONFIG_ACPI_BUTTON=m
CONFIG_ACPI_FAN=m
CONFIG_ACPI_PROCESSOR=m
CONFIG_ACPI_THERMAL=m

but if I copy this to /usr/src/linux-2.4/.config and make xconfig
and save the configuration all this disappears 
so it is a bug configuration is not correct.

cat /var/log/dmesg | grep -i acpi
 BIOS-e820: 00000000f7fd0000 - 00000000f7fdfc00 (ACPI data)
ACPI: Searched entire block, no RSDP was found.
ACPI: RSDP located at physical address c00fdc20
ACPI table found: RSDT v1 [DELL   PE2600   0.1]
ACPI table found: FACP v1 [DELL   PE2600   0.1]
ACPI table found: APIC v1 [DELL   PE2600   0.1]
LAPIC (acpi_id[0x0001] id[0x0] enabled[1])
LAPIC (acpi_id[0x0002] id[0x6] enabled[1])
LAPIC (acpi_id[0x0003] id[0x1] enabled[1])
LAPIC (acpi_id[0x0004] id[0x7] enabled[1])
LAPIC_NMI (acpi_id[0x0001] polarity[0x1] trigger[0x1] lint[0x1])
LAPIC_NMI (acpi_id[0x0002] polarity[0x1] trigger[0x1] lint[0x1])
LAPIC_NMI (acpi_id[0x0003] polarity[0x1] trigger[0x1] lint[0x1])
LAPIC_NMI (acpi_id[0x0004] polarity[0x1] trigger[0x1] lint[0x1])
ACPI table found: SPCR v1 [DELL   PE2600   0.1]
Enabling the CPU's according to the ACPI table
ACPI tables and CPU MSR values mismatch about cpu number


thanks
Comment 4 Arjan van de Ven 2004-04-14 07:52:24 EDT
acpi tables are parsed during boot and that's what you paste. No other
acpi is present for x86, nor can be compiled in.

The config snippets you paste are meaningless; # CONFIG_ACPI is not
set is before teh bit you pasted and that overrules anything else. If
you want to draw definite conclusions about our configs you need to
run them through "make oldconfig" first. (yes I know ugly but not
fixable in the 2.4 rpm context)

Note You need to log in before you can comment on or make changes to this bug.