Bug 114670 - traceback while installing system-config-mouse [pt_BR.UTF-8]
Summary: traceback while installing system-config-mouse [pt_BR.UTF-8]
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-30 21:28 UTC by Mike McLean
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-04 20:33:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike McLean 2004-01-30 21:28:07 UTC
* FC2-re0129.2
* Portuguese (Brazilian) [pt_BR.UTF-8]
* kickstart

This happened during the 'all_lang' testcase, which is a series of
nearly identical kickstarts (only the lang, langsupport, and timezone
lines change).  The case got all the way to pt_BR (16 out of 21)
before it hit this traceback.  (Excepting the ja,ko,and zh language
installs which are currently skipped due to another bug).

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 1047, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 242, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 766, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 168, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 236, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 880, in doInstall
    problems = ts.run(cb.cb, 0)
  File "/usr/lib/anaconda/packages.py", line 425, in cb
    self.progress.completePackage(h, self.pkgTimer)
  File "/usr/lib/anaconda/iw/progress_gui.py", line 167, in
completePackage
    str = _("Remaining time: %s minutes") %
((int(timeest/timefactor)+1)*timefactor,)
TypeError: not all arguments converted during string formatting

Comment 2 Jeremy Katz 2004-01-31 18:59:05 UTC
Fixed in CVS.  Bad pofile, no cookie! :)

Comment 3 Mike McLean 2004-02-04 20:33:30 UTC
Yep, fixed now.


Note You need to log in before you can comment on or make changes to this bug.