Bug 1146766 - [GSS] (6.3.x) @UseAsyncMethod doesn't seem to work on JBoss
Summary: [GSS] (6.3.x) @UseAsyncMethod doesn't seem to work on JBoss
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Services
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Alessio Soldano
QA Contact: Rostislav Svoboda
Russell Dickenson
URL:
Whiteboard:
Depends On: 1146764
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-26 03:13 UTC by Tadayoshi Sato
Modified: 2018-12-09 18:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1146764
Environment:
Last Closed: 2014-09-29 01:18:36 UTC
Type: Bug


Attachments (Terms of Use)
reproducer (9.83 KB, application/zip)
2014-09-26 03:13 UTC, Tadayoshi Sato
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1146764 0 high CLOSED [GSS] (6.4.0) @UseAsyncMethod doesn't seem to work on JBoss 2021-02-22 00:41:40 UTC
Red Hat Issue Tracker JBWS-3833 0 Major Closed @UseAsyncMethod doesn't seem to work on JBoss 2015-04-25 20:27:50 UTC

Description Tadayoshi Sato 2014-09-26 03:13:16 UTC
Created attachment 941359 [details]
reproducer

+++ This bug was initially created as a clone of Bug #1146764 +++

Description of problem:
Platform BZ for https://issues.jboss.org/browse/JBWS-3833

I developed the following WS endpoint that uses @UseAsyncMethod:

@WebService(...)
public class GreetingServiceImpl implements GreetingService {
    ...
    @WebMethod
    @UseAsyncMethod
    public String hello(String name) { ... }

    public Future<HelloResponse> helloAsync(final String name, final AsyncHandler<HelloResponse> asyncHandler) { ... }

My expectation with @UseAsyncMethod is that whenever the hello() operation is invoked helloAsync() is eventually executed on JBoss (WildFly 8 or EAP 6). However, it really is not.

I tested the same endpoint by launching it using Endpoint.publish(...) as well and it works as expected, so I don't think it's an issue with CXF itself but with JBoss WS integration.

Attached please see the complete reproducer project async.zip for detail.

Version-Release number of selected component (if applicable):
JBoss WS CXF

How reproducible:
100%

Steps to Reproduce:
1. Deploy the reproducer (async.zip).
2. Invoke the 'hello' operation from SoapUI or any other WS client.
3. Check the server log.

Actual results:
You'll see the following message in the server log:
INFO  [com.redhat.samples.ws.GreetingServiceImpl] (default task-13) Hello, SoapUI! (SYNC)

Expected results:
The following message should be seen in the server log instead:
INFO  [com.redhat.samples.ws.GreetingServiceImpl] (default task-13) Hello, SoapUI! (ASYNC)

Comment 1 JBoss JIRA Server 2014-09-26 12:55:10 UTC
Alessio Soldano <asoldano> updated the status of jira JBWS-3833 to Resolved

Comment 2 Tadayoshi Sato 2014-09-29 01:18:36 UTC
Closed the ticket as it's not a bug.

Comment 4 JBoss JIRA Server 2015-04-25 20:27:51 UTC
Alessio Soldano <asoldano> updated the status of jira JBWS-3833 to Closed


Note You need to log in before you can comment on or make changes to this bug.