Bug 1146995 - CONFIG_CHECKPOINT_RESTORE isn't set in the ARM kernel config
Summary: CONFIG_CHECKPOINT_RESTORE isn't set in the ARM kernel config
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: armv7hl
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-26 14:06 UTC by Andrew Vagin
Modified: 2015-01-15 03:27 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-15 03:27:07 UTC


Attachments (Terms of Use)

Description Andrew Vagin 2014-09-26 14:06:52 UTC
Description of problem:

The CONFIG_CHECKPOINT_RESTORE options is required for the criu package. It's enabled for x86_64.

$ cat /boot/config-3.16.2-201.fc20.x86_64 | grep CHECKPO
CONFIG_CHECKPOINT_RESTORE=y

# yum search criu
Loaded plugins: langpacks, refresh-packagekit
========================================================================== N/S matched: criu ===========================================================================
criu-devel.armv7hl : Header files and libraries for criu
criu.armv7hl : Tool for Checkpoint/Restore in User-space

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. # cat /boot/config-3.16.3-200.fc20.armv7hl | grep CHECKP

Actual results:
# CONFIG_CHECKPOINT_RESTORE is not set

Expected results:
CONFIG_CHECKPOINT_RESTORE=y

Additional info:

Comment 1 Peter Robinson 2014-09-27 17:02:18 UTC
Will investigate

Comment 2 Justin M. Forbes 2014-11-13 15:55:29 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 20 kernel bugs.

Fedora 20 has now been rebased to 3.17.2-200.fc20.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 21, and are still experiencing this issue, please change the version to Fedora 21.

If you experience different issues, please open a new bug report for those.

Comment 3 Andrew Vagin 2014-11-13 17:26:15 UTC
[avagin@localhost tmp]$  rpm2cpio kernel-core-3.17.2-300.fc21.armv7hl.rpm | cpio -i -d 
100221 blocks
[avagin@localhost tmp]$ cat boot/config-3.17.2-300.fc21.armv7hl | grep CHECKP
# CONFIG_CHECKPOINT_RESTORE is not set

Comment 4 Andrew Vagin 2014-12-26 13:29:42 UTC
Any news? CONFIG_CHECKPOINT_RESTORE is set for x86_64. It doesn't enable arch-specific code, so it should be safe to set this option for arm too.

Comment 5 Peter Robinson 2014-12-26 14:09:03 UTC
Any reason not to set it for all architectures (PPC/s390) too?

Comment 6 Andrew Vagin 2014-12-26 14:18:05 UTC
I don't see such reasons.

JFYI: I am not sure that anyone except CRIU uses checkpoint/restore functionality in kernel. CRIU suports x86_64, ARM, ARM64.

Comment 7 Peter Robinson 2015-01-15 03:27:07 UTC
kernel now built with support in F-22 (kernel-3.19.0-0.rc4.git2.1.fc22)


Note You need to log in before you can comment on or make changes to this bug.