Bug 1147033 - Organization Editor: Clicking the multi-select plus icon adds items that were filtered out
Summary: Organization Editor: Clicking the multi-select plus icon adds items that were...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Organizations and Locations
Version: 6.0.0
Hardware: All
OS: Linux
unspecified
low vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-26 16:13 UTC by jcallaha
Modified: 2019-09-25 21:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:45:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 7726 None None None 2016-04-22 17:01:06 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description jcallaha 2014-09-26 16:13:41 UTC
Description of problem: In the Organization Editor, when filtering out any of the categories (e.g. Capsules, Media), clicking the "+" icon will add all original items. From a UX perspective, the icon should only add the items that weren't filtered out.


Version-Release number of selected component (if applicable): 6.0


How reproducible: always


Steps to Reproduce:
1. Enter the Organization Editor for any organization
2. Select any of the categories on the bottom left (e.g. Users, Subnets)
3. Apply a filter to limit the select-able options
4. Click the "+" icon

Actual results: Adds all options, including those filtered out.


Expected results: Should only add options that have not been filtered out.


Additional info: None

Comment 1 RHEL Program Management 2014-09-26 16:23:16 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Dominic Cleal 2014-09-29 08:32:16 UTC
Created redmine issue http://projects.theforeman.org/issues/7726 from this bug

Comment 4 Bryan Kearney 2015-08-25 18:08:09 UTC
Upstream bug component is WebUI

Comment 5 Bryan Kearney 2016-03-09 15:06:55 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/7726 has been closed
-------------
Ondřej Pražák
Applied in changeset commit:45be57cddfcc8d8895a96cd601c6ff132caacd8c.

Comment 6 jcallaha 2016-03-16 20:10:45 UTC
Verified in Satellite 6.2 Beta Snap 4. Behavior is as expected.

Comment 9 errata-xmlrpc 2016-07-27 08:45:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.