Bug 1147056 - Rubygem-Staypuft: Nova+vlan deployment: The number of vlan range against "Fixed IP range for tenant networks" isn't validated although may fail a deployment.
Summary: Rubygem-Staypuft: Nova+vlan deployment: The number of vlan range against "Fix...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z2
: Installer
Assignee: Mike Burns
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-26 17:26 UTC by Alexander Chuzhoy
Modified: 2014-11-04 17:02 UTC (History)
5 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.4.0-1.el6ost
Doc Type: Bug Fix
Doc Text:
The Red Hat Enterprise Linux OpenStack Platform Installer will now validate the configured range of fixed IPs for tenant networks before deploying OpenStack. If a user attempts to use ranges that would result in an error, the installer will now notify the user before proceeding with the deployment.
Clone Of:
Environment:
Last Closed: 2014-11-04 17:02:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description Alexander Chuzhoy 2014-09-26 17:26:26 UTC
Rubygem-Staypuft: Nova+vlan deployment: The number of vlan range against "Fixed IP range for tenant networks" isn't validated  although may fail a deployment.

Environment:
rhel-osp-installer-0.3.6-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-foreman-installer-2.0.26-1.el6ost.noarch
openstack-puppet-modules-2014.1-21.8.el6ost.noarch

Steps to reproduce:
1. install rhel-osp-installer.
2. Configure an HANova deployment with Vlan tenant network type.
3. In the Nova service configuration:
   a. Set the "vlan range" to 10:15
   b. Set the "Fixed IP range for tenant networks" to 192.168.100.96/28
   c. Configure a desired "Floating IP range for external network" per need.

4. Start a deployment.

Result:
The deployment will fail installing the compute nodes. There will be a puppet error like similar:
change from absent to present failed: Execution of '/usr/bin/nova-manage network create novanetwork 192.168.100.96/28 6 --vlan_start 10' returned 1: Command failed, please check log for more info

Expected result:
The deployment should complete successfully with the configured values, so the values need to be validated.

Comment 1 Scott Seago 2014-09-26 17:28:39 UTC
Fixed in https://github.com/theforeman/staypuft/pull/320

Comment 4 Alexander Chuzhoy 2014-10-06 17:19:30 UTC
Verified: rhel-osp-installer-0.4.1-2.el6ost.noarch
ruby193-rubygem-staypuft-0.4.0-2.el6ost.noarch


The "Fixed IP range for tenant networks" is verified now (to allow at least 4 IP address per subnet: 2 usable + network address + broadcast).

In case the input is wrong, the user is notified. For example:
Fixed range is too small. Specify CIDR for network size /29 or larger

Corrected the range according to the suggestion and had a successful deployment.

Submitted BZ#1149813 to slightly extend the validation message.

Comment 8 errata-xmlrpc 2014-11-04 17:02:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.