Bug 1147077 - rubygem-staypuft: HANeutron deployment with "Tenant Network Type" set to "VLAN Segmentation" fails installing the controllers. Puppet error: /usr/sbin/rabbitmqctl set_policy HA '^(?!amq\.).*' '{"ha-mode": "all"}' returned 2 instead of one of [0].
Summary: rubygem-staypuft: HANeutron deployment with "Tenant Network Type" set to "VL...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: z2
: Installer
Assignee: John Eckersberg
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-26 20:13 UTC by Alexander Chuzhoy
Modified: 2014-11-04 17:02 UTC (History)
5 users (show)

Fixed In Version: openstack-foreman-installer-2.0.28-1.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-04 17:02:52 UTC
Target Upstream Version:


Attachments (Terms of Use)
/var/log/messages file from the controllers (146.86 KB, application/x-gzip)
2014-09-26 20:20 UTC, Alexander Chuzhoy
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description Alexander Chuzhoy 2014-09-26 20:13:03 UTC
rubygem-staypuft:  HANeutron deployment with "Tenant Network Type" set to "VLAN Segmentation" fails installing the controllers. Puppet error: /usr/sbin/rabbitmqctl set_policy HA '^(?!amq\.).*' '{"ha-mode": "all"}' returned 2 instead of one of [0].


Environment:
rhel-osp-installer-0.3.6-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-foreman-installer-2.0.26-1.el6ost.noarch
openstack-puppet-modules-2014.1-21.8.el6ost.noarch

Steps to reproduce:
1. install rhel-osp-installer.
2. Create and run an HA Neutron deployment with vlan network type:
   a. Tenant (VM Data) VLAN Ranges:  10-15
   b. The tenant network is 192.168.100.0/21


Results:
The deployment gets paused with errors on 60% installing the controllers.
Checking the puppet reports - see the following error on one controller:
 	change from notrun to 0 failed: /usr/sbin/rabbitmqctl set_policy HA '^(?!amq\.).*' '{"ha-mode": "all"}' returned 2 instead of one of [0]

Expected result:
The deployment should complete with no issues.

Comment 1 Alexander Chuzhoy 2014-09-26 20:20:28 UTC
Created attachment 941701 [details]
/var/log/messages file from the controllers

Comment 4 Alexander Chuzhoy 2014-10-06 19:55:08 UTC
Verified: rhel-osp-installer-0.4.1-2.el6ost.noarch



Didn't reproduce. The deployment has completed successfully.

Comment 6 errata-xmlrpc 2014-11-04 17:02:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.