Bug 1147202 - [virtio-win][WHQL][netkvm]Job named by InvalidPackets induce win81-32/64 to hang up.
Summary: [virtio-win][WHQL][netkvm]Job named by InvalidPackets induce win81-32/64 to h...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard: Fixed_Not_Ship
: 1145441 1147188 1147190 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-28 05:55 UTC by Min Deng
Modified: 2015-11-24 08:44 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2015-11-24 08:44:28 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot (163.50 KB, image/png)
2014-09-28 05:58 UTC, Min Deng
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1147188 None None None Never
Red Hat Product Errata RHBA-2015:2513 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2015-11-24 13:38:38 UTC

Internal Links: 1147188

Description Min Deng 2014-09-28 05:55:39 UTC
Description of problem:
Job named by InvalidPackets induce win81-32/64 to hang up.

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.1.0-4.el7.x86_64
kernel-3.10.0-165.el7.x86_64
seabios-1.7.5-4.el7.x86_64
virtio-win-prewhql-92
How reproducible:
10 times/10 times 
Steps to Reproduce:
1.boot up guest with the following 

Guest1
  /usr/libexec/qemu-kvm -name 092NICBLUE64CID -enable-kvm -m 6G -smp 4 -uuid eaf368c4-a012-433e-ab47-1a6075c688f3 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/092NICBLUE64CID,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=092NICBLUE64CID,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_8_1_enterprise_x64_dvd_2971902.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=092NICBLUE64CID.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:34:01:b8:ea,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:2 -vga cirrus -netdev tap,script=/etc/qemu-ifup-private,downscript=no,id=hostnet1,vhost=on -device virtio-net-pci,netdev=hostnet1,id=net1,mac=00:52:36:08:8a:b4,bus=pci.0,mq=on

Guest2,
/usr/libexec/qemu-kvm -name 092NICBLUE64SID -enable-kvm -m 6G -smp 4 -uuid a4eab5f3-d335-4e2c-b32d-ceb5122a12ba -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/092NICBLUE64SID,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=092NICBLUE64SID,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_8_1_enterprise_x64_dvd_2971902.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=092NICBLUE64SID.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:19:00:6d:7c,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:3 -vga cirrus -netdev tap,script=/etc/qemu-ifup-private,downscript=no,id=hostnet1,vhost=on -device virtio-net-pci,netdev=hostnet1,id=net1,mac=00:52:68:5b:c1:7b,bus=pci.0,mq=on
2.Submit the job 

Actual results:
The guest hang up the cursor could not operate.
Expected results:
The job could pass

Additional info:
  The job could not pass on win2008R2 and win2012/2012R2 too but we can get dmp files,see bug Bug 1147188,Bug 1147190
 The job just let win81-32/64 guest freeze and user has to reset the guest,Besides it won't generate dump files.So I only save the HCK and screenshot for this bug and please find them from the below location.

Comment 1 Min Deng 2014-09-28 05:58:00 UTC
Created attachment 941949 [details]
Screenshot

Comment 5 Yossi Hindin 2014-10-12 07:24:32 UTC
*** Bug 1147188 has been marked as a duplicate of this bug. ***

Comment 6 Yossi Hindin 2014-10-12 07:27:09 UTC
*** Bug 1147190 has been marked as a duplicate of this bug. ***

Comment 7 Yossi Hindin 2014-10-12 07:30:20 UTC
*** Bug 1145441 has been marked as a duplicate of this bug. ***

Comment 9 lijin 2015-03-30 06:52:52 UTC
with build101,job can pass on win8.1 guests.
so this issue has been fixed already.

Comment 12 lijin 2015-07-17 07:10:21 UTC
change status to verified according to comment#9

Comment 14 errata-xmlrpc 2015-11-24 08:44:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html


Note You need to log in before you can comment on or make changes to this bug.