Bug 114724 - GUI_functions.py:524:gui_run_dialog:OSError: [Errno 1] Operation not permitted
GUI_functions.py:524:gui_run_dialog:OSError: [Errno 1] Operation not permitted
Status: CLOSED DUPLICATE of bug 109604
Product: Fedora
Classification: Fedora
Component: redhat-config-network (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-01 12:13 EST by Tony Cox
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tony Cox 2004-02-01 12:13:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
This problem happens while trying to activate a ppp0 interface using
the Smart Link slmodem linmoden software.  A bug in the slmodem driver
causes the redhat-config-network to try an illegal operation.


Version-Release number of selected component (if applicable):
redhat-config-network-1.3.10-1

How reproducible:
Always

Steps to Reproduce:
1. run slmodem without removing the data file (slmodem works if file
is removed)
2. try to activate the ppp0 interface
3. error report is issued when line is deactivated
    

Additional info:

Component: redhat-config-network
Version: 1.3.10
Summary: TB3fbf821d GUI_functions.py:524:gui_run_dialog:OSError:
[Errno 1] Operation not permitted
Traceback (most recent call last):
  File "/usr/bin/redhat-control-network", line 184, in
on_activateButton_clicked
    (ret, msg) = dev.activate()
  File
"/usr/src/build/320592-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDevice.py",
line 385, in activate
    dialog = dialog)
  File
"/usr/src/build/320592-noarch/install/usr/share/redhat-config-network/netconfpkg/NC_functions.py",
line 512, in generic_run_dialog
    dialog = dialog)
  File
"/usr/src/build/320592-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/GUI_functions.py",
line 524, in gui_run_dialog
OSError: [Errno 1] Operation not permitted

Local variables in innermost frame:
fdin: []
swindow: <gtk.ScrolledWindow object (GtkScrolledWindow) at 0x91b2fe4>
string: <module 'string' from '/usr/lib/python2.2/string.pyc'>
okbutton: <gtk.Button object (GtkButton) at 0x91b304c>
buffer: <gtk.TextBuffer object (GtkTextBuffer) at 0x92b1ff4>
cancelbutton: <gtk.Button object (GtkButton) at 0x91ec324>
command: /sbin/ifup
argv: ['/sbin/ifup', 'worldnet', 'up']
searchPath: 0
label: Activating network device worldnet, please wait...
lbl: <gtk.Label object (GtkLabel) at 0x91b2fbc>
select: <module 'select' from
'/usr/lib/python2.2/lib-dynload/selectmodule.so'>
stdin: 0
xml: <gtk.glade.XML object (GladeXML) at 0x91ebad4>
catchfd: (1, 2)
fderr: []
dlg: <gtk.Dialog object (GtkDialog) at 0x9150a4c>
errlabel: Cannot activate network device worldnet!

fdout: []
root: /
gtk: <module 'gtk' from
'/usr/lib/python2.2/site-packages/gtk-2.0/gtk/__init__.pyc'>
CancelException: netconfpkg.gui.GUI_functions.CancelException
mark: <gtk.TextMark object (GtkTextMark) at 0x92b42ec>
write: 4
read: 3
s: 1
childpid: 5630
closefd: -1
dialog: None
rc:
title: redhat-config-network:

Network device activating...
os: <module 'os' from '/usr/lib/python2.2/os.pyc'>
textview: <gtk.TextView object (GtkTextView) at 0x91fc95c>
Comment 1 Harald Hoyer 2004-02-02 03:36:52 EST

*** This bug has been marked as a duplicate of 109604 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:01:01 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.