Bug 1147271 - Add warnings to ensure users don't report issues to winehq.org (because of compholio patches)
Summary: Add warnings to ensure users don't report issues to winehq.org (because of co...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wine
Version: rawhide
Hardware: All
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-28 18:39 UTC by Sebastian Lackner
Modified: 2014-10-21 12:10 UTC (History)
6 users (show)

Fixed In Version: wine-1.7.28-1.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-12 05:00:34 UTC


Attachments (Terms of Use)

Description Sebastian Lackner 2014-09-28 18:39:48 UTC
Description of problem:

As the Fedora Wine build contains our compholio patchset ( https://github.com/compholio/wine-compholio ), it happens from time to time that users report issues caused by our patchset to upstream wine, instead to us directly. This is confusing for other Wine developers, because they get reports about regressions or other issues, which cannot be reproduced in the regular Wine version.

I can understand that Fedora doesn't want to provide two separate Wine versions, but I think it should be made a bit more clear, that this version is patched, and that users have to check with regular Wine before reporting issues. All reports at winehq.org should contain at least a note if they have our patchset applied, so that people trying to help don't have to figure out, if its a patched version or not.

Some example bug reports:

https://bugs.winehq.org/show_bug.cgi?id=37143
https://bugs.winehq.org/show_bug.cgi?id=37278

(maybe even some more, but most people don't mention which distro they use, so it requires a bit of luck to figure out that its an issue caused by the patchset.)

How reproducible:

Actual results:

Expected results:

The user should be informed that Wine bugs shouldn't be reported to winehq.org - for example by using some postinstall information, modified manpage, ... We offer an issue at https://github.com/compholio/wine-compholio/issues for all issues which are caused by the compholio patchset.

Additional info:

Comment 1 Michael Schwendt 2014-09-29 08:35:20 UTC
> for example by using some postinstall information

Fedora RPM packages are not supposed to display anything during post-install, so at most a README.bug-reporting (or similar) could be added in addition to a prominent notification in the package %description.

A problem will be that users will still make assumptions about what the upstream is and where to report bugs. Extra README files are no bullet-proof way to make them aware of special patches.

http://fedoraproject.org/wiki/Staying_close_to_upstream_projects

Comment 2 Sebastian Lackner 2014-10-02 19:41:55 UTC
As already mentioned before, I personally would really prefer if Fedora would decide to provide Wine-Compholio (dependency of Pipelight) as a separate package, and ship their regular Wine version without any patches, to avoid all these issues in general.

Nevertheless, as this will probably not happen in the near future, we decided [1] to add warnings directly into our patches [2], which will be present in >= 1.7.28. This will make people on the Wine bug tracker aware that a patched version is used, and they can mark the bug report as invalid and redirect them to us, if they think it could be our fault.

It is not really a perfect solution, especially as people on the bug tracker might also close bugs describing valid issues present in vanilla Wine. Nevertheless we don't really have any influence on that, and we also informed the Fedora maintainers about exactly these possible consequences when they were discussing adding the Compholio patchset some time ago.

As the warnings introduced by my patch should be sufficient, the "main issue" is basically resolved - but the question is, if the current solution is good enough, or if some other solution (more warnings? separate package?) should be used instead. What do you guys think?

Regards,
Sebastian

[1] https://www.winehq.org/pipermail/wine-devel/2014-October/105358.html
[2] https://github.com/compholio/wine-compholio/commit/2616a89d50f4c1fab7c12ba4c4340cfe8d5f4198

Comment 3 Fedora Update System 2014-10-06 06:20:18 UTC
wine-1.7.28-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/wine-1.7.28-1.fc21

Comment 4 Fedora Update System 2014-10-06 06:21:41 UTC
wine-1.7.28-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/wine-1.7.28-1.fc20

Comment 5 Fedora Update System 2014-10-06 06:22:48 UTC
wine-1.7.28-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/wine-1.7.28-1.fc19

Comment 6 Fedora Update System 2014-10-08 18:54:12 UTC
Package wine-1.7.28-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wine-1.7.28-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-12286/wine-1.7.28-1.fc21
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2014-10-12 05:00:34 UTC
wine-1.7.28-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2014-10-14 04:37:03 UTC
wine-1.7.28-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2014-10-17 08:35:27 UTC
wine-1.7.28-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Hynek Černoch 2014-10-21 12:10:43 UTC
My cron tasks failed for several days until I have fixed scripts so that this new error messages should be ignored.

I think that such messages are not so important that it must be added into stable releases (Fedora 20). In a new release it would be normal.


Note You need to log in before you can comment on or make changes to this bug.