Bug 114736 - emacs other-frame command doesn't work
Summary: emacs other-frame command doesn't work
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs
Version: 1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-02 05:47 UTC by Theodore C. Belding
Modified: 2007-11-30 22:10 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2005-02-13 15:53:17 UTC


Attachments (Terms of Use)

Description Theodore C. Belding 2004-02-02 05:47:47 UTC
Description of problem:
When more than one frame is open, other-frame (C-x 5 o) should switch
between open frames, angalogous to C-x o between windows. This doesn't
work properly. I'm not sure if this is actually a problem with emacs,
or with the window manager or window manager default settings
(metacity-2.6.3-1)

Version-Release number of selected component (if applicable):
emacs-21.3-7

How reproducible:
Always

Steps to Reproduce:
1. Run emacs
2. Type "C-x 5 2" to open a new frame (focus switches to new frame)
3. Type "C-x 5 o" to switch back to original frame
  
Actual results:
Original frame is raised, as expected, but focus remains in second
frame (where it was before C-x 5 o)

Expected results:
Focus should be transferred back to the original frame

Additional info:

Comment 1 Jens Petersen 2004-04-15 15:54:28 UTC
Reproduced in the default click-to-focus of metacity, and under
kde wm too.

I have a feeling this has never really worked for Emacs.
XEmacs looks to be fine on this. :)

Alternatively if you don't mind you can use focus-follows-mouse
with Emacs which seems to be ok.

I recommend reporting this upstream to emacs-devel.

Comment 2 Theodore C. Belding 2004-04-15 16:01:16 UTC
I reported this upstream using the emacs bug report tool in the help
menu back in February. No response yet.

Comment 3 Theodore C. Belding 2004-04-28 23:38:36 UTC
I guess I misunderstood your comment above regarding
focus-follows-mouse. Setting that to nil does indeed fix the problem
for me, for instance by adding this to my .emacs file:

;; set focus-follows-mouse to nil (so that switching frames works
;; properly under the default click-to-focus setting in metacity)
(setq focus-follows-mouse nil)

Would it be possible to add these lines to /etc/skel/.emacs? Or change
the default setting some other way?

This seems more like an emacs configuration problem under Fedora,
rather than a bug in emacs itself, so I won't report this upstream,
unless I hear from you that I should. Thanks!



Comment 4 Jens Petersen 2004-04-30 04:00:37 UTC
Yes, good point: I will add this to default.el I think for fc3.
Thank you.

Comment 5 Jens Petersen 2004-09-29 11:29:15 UTC
Adding this in 21.3-15.

Comment 6 Jens Petersen 2004-09-29 16:33:28 UTC
Actually this change was already in default.el in 21.3-13...


Note You need to log in before you can comment on or make changes to this bug.