Bug 1147523 - missing group info environment group support
missing group info environment group support
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Honza Silhan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-09-29 09:08 EDT by Parag Nemade
Modified: 2014-12-13 04:53 EST (History)
5 users (show)

See Also:
Fixed In Version: dnf-0.6.3-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-13 04:53:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Parag Nemade 2014-09-29 09:08:18 EDT
Description of problem:
on F21 system, I ran the command
$ sudo dnf group info "LXDE Desktop"
Warning: Group LXDE Desktop does not exist.


Version-Release number of selected component (if applicable):
$ rpm -qa | grep dnf
python3-dnf-0.6.1-1.fc21.noarch
dnf-langpacks-0.3.1-2.fc21.noarch
dnf-0.6.1-1.fc21.noarch
dnf-plugins-core-0.1.3-1.fc21.noarch


How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
says group does not exist

Expected results:
it should provide information about LXDE group

Additional info:

I see many other groups are also not working. So looks like issue with "info" option to "dnf group" command
Comment 1 Parag Nemade 2014-09-29 09:17:05 EDT
I tried to query for all installed/available group/environments and output is

Warning: Group Cinnamon Desktop does not exist.
Warning: Group Development and Creative Workstation does not exist.
Warning: Group Fedora Cloud Server does not exist.
Warning: Group Fedora Server does not exist.
Warning: Group Fedora Workstation does not exist.
Warning: Group GNOME Desktop does not exist.
Warning: Group Infrastructure Server does not exist.
Warning: Group KDE Plasma Workspaces does not exist.
Warning: Group LXDE Desktop does not exist.
Warning: Group MATE Desktop does not exist.
Warning: Group Minimal Install does not exist.
Warning: Group Web Server does not exist.
Warning: Group Xfce Desktop does not exist.
Comment 2 Tim Lauridsen 2014-09-29 11:15:11 EDT
This is a little strange
sudo dnf group list -v | grep -i lxde

   LXDE Desktop (lxde-desktop-environment)

The following works:

sudo dnf group info "lxde" 
sudo dnf group info "LXDE"
sudo dnf group info "lxde-desktop"

The following dont work

sudo dnf group info "lxde-desktop-environment"
sudo dnf group info "LXDE Desktop"
Comment 3 Parag Nemade 2014-09-29 12:08:00 EDT
I guess whichever group we are passing if its mentioned in comps as <groupid>....</groupid> or in a <group>.....</group> then only its working otherwise not.
Comment 4 Honza Silhan 2014-09-30 14:23:08 EDT
Hi, thanks for the report. Now DNF doesn't handle environment groups from 'group info' command. I'll take a look.
Comment 5 Honza Silhan 2014-10-08 16:06:19 EDT
Fixed in the upstream.
Comment 6 Fedora Update System 2014-12-09 09:06:30 EST
dnf-0.6.3-2.fc21,dnf-plugins-core-0.1.4-1.fc21,hawkey-0.5.2-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnf-0.6.3-2.fc21,dnf-plugins-core-0.1.4-1.fc21,hawkey-0.5.2-1.fc21
Comment 7 Fedora Update System 2014-12-11 23:32:34 EST
Package dnf-0.6.3-2.fc21, hawkey-0.5.2-1.fc21, dnf-plugins-core-0.1.4-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.6.3-2.fc21 hawkey-0.5.2-1.fc21 dnf-plugins-core-0.1.4-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-16760/dnf-0.6.3-2.fc21,dnf-plugins-core-0.1.4-1.fc21,hawkey-0.5.2-1.fc21
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2014-12-13 04:53:35 EST
dnf-0.6.3-2.fc21, hawkey-0.5.2-1.fc21, dnf-plugins-core-0.1.4-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.