Bug 114756 - inaccurate, useless debug message from giftopnm with no way to turn it off
Summary: inaccurate, useless debug message from giftopnm with no way to turn it off
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: netpbm   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-02 14:23 UTC by Jonathan Kamens
Modified: 2015-03-05 01:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-09 15:59:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2004-02-02 14:23:50 UTC
When I convert a simple gif file to pnm with giftopnm in the current 
netpbm, I get this message:

giftopnm: Reading Image Sequence 0

There are several problems here:

1) The -image option to giftopnm starts numbering the sequenced 
images from 1, not 0.  This message should be consistent and say 1, 
not 0.

2) This message probably shouldn't appear by default.  It should only 
apear if -verbose is specified.

3) If it must appear by default, there should be a -quiet option to 
make it go away or something.  Redirecting stderr to /dev/null to 
make it go away is bad because then real error messages would also be 
lost.

Comment 1 Phil Knirsch 2004-02-09 15:59:43 UTC
Fixed in netpbm-10.19-3 and later, removed the annoying message by
default, only appears when using -verbose.

Also fixed the numbering, now starts with 1 instead of 0.

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.