Bug 1147577 - installing osp5 rhel7 hosts fails automatically if boot disk is > 2TB
Summary: installing osp5 rhel7 hosts fails automatically if boot disk is > 2TB
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhel-osp-installer
Version: 5.0 (RHEL 6)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: z2
: Installer
Assignee: Brad P. Crochet
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-29 14:10 UTC by Kambiz Aghaiepour
Modified: 2014-11-04 17:02 UTC (History)
5 users (show)

Fixed In Version: rhel-osp-installer-0.4.2-1.el6ost
Doc Type: Bug Fix
Doc Text:
Previously, GUID partition table (GPT) partitions greater than 2 TB required a BIOS boot partition which was not created. This meant that installing to disks larger that 2 TB would fail. With this update, if the disk is larger than 2TB, a BIOS boot partition is created, and nodes with disks larger than 2 TB will boot correctly.
Clone Of:
Environment:
Last Closed: 2014-11-04 17:02:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description Kambiz Aghaiepour 2014-09-29 14:10:12 UTC
Description of problem:

If the OS boot disk on the RHEL7 hosts is larger than 2TB, the automatic installation fails.

Version-Release number of selected component (if applicable):

Latest puddle

How reproducible:

Attempt a kickstart of RHEL7 OSP hosts using any deployment, with the OS disks configured (e.g. via perc controller to use a RAID5 device across multiple internal drives).

The workaround is to add the following to the partition scheme "OpenStack Default" :

part biosboot --fstype=biosboot --size=1

(immediately after the "clearpart --all --initlabel")

The above workaround was gathered after reading:

https://bugzilla.redhat.com/show_bug.cgi?id=1032428

(see comment #9 and comment #15).  Since a custom partition is used, we need to add some logic to determine if the size of sda is > 2TB, and ensure the creation of the biosboot partition.

Comment 1 Kambiz Aghaiepour 2014-09-29 14:11:49 UTC
The comments being referenced, i.e. 9 and 15, are comments against 1032428, not this bz entry.

Comment 5 Brad P. Crochet 2014-10-07 15:32:11 UTC
PR available: https://github.com/theforeman/foreman-installer-staypuft/pull/100

Comment 10 errata-xmlrpc 2014-11-04 17:02:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.