Bug 1147847 - error message should be improved when use domtime to a shutoff guest
Summary: error message should be improved when use domtime to a shutoff guest
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.1
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Michal Privoznik
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-30 08:16 UTC by Luyao Huang
Modified: 2015-11-19 05:53 UTC (History)
5 users (show)

Fixed In Version: libvirt-1.2.15-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 05:53:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2202 0 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2015-11-19 08:17:58 UTC

Description Luyao Huang 2014-09-30 08:16:33 UTC
description of problem:
error message should be improved when use domtime to a shutoff guest

Version-Release number of selected component (if applicable):
libvirt-1.2.8-4.el7.x86_64


How reproducible:
100%

Steps to Reproduce:

1.prepare a shutoff vm

# virsh list --all
 Id    Name                           State
----------------------------------------------------
 -     r6                             shut off

2.# virsh domtime r6 --time 123
error: Operation not supported: cannot set time: qemu doesn't support rtc-reset-reinjection command

3.# virsh domtime r6 --sync
error: Operation not supported: cannot set time: qemu doesn't support rtc-reset-reinjection command

4.# virsh domtime r6 --now
error: Operation not supported: cannot set time: qemu doesn't support rtc-reset-reinjection command


Actual results:
error: Operation not supported: cannot set time: qemu doesn't support rtc-reset-reinjection command

Expected results:
error: Requested operation is not valid: domain is not running



Additional info:

Comment 2 Michal Privoznik 2014-10-03 13:55:05 UTC
I've just pushed the patch upstream:

commit a4771c58604a8368fbc5e79e73cd54bfecca44ef
Author:     Shanzhi Yu <shyu@redhat.com>
AuthorDate: Tue Sep 30 21:36:23 2014 +0800
Commit:     Michal Privoznik <mprivozn@redhat.com>
CommitDate: Fri Oct 3 15:48:07 2014 +0200

    qemu: Improve domainSetTime error info report
    
    check domain's status before call virQEMUCapsGet to report a accurate
    error when domain is shut off
    
    Resolve: https://bugzilla.redhat.com/show_bug.cgi?id=1147847
    Signed-off-by: Shanzhi Yu <shyu@redhat.com>


v1.2.9-28-ga4771c5

Comment 3 Michal Privoznik 2015-04-27 05:18:58 UTC
This should be in POST per comment 2.

Comment 5 zhenfeng wang 2015-05-26 09:04:24 UTC
Verify this bug with libvirt-1.2.15-2.el7.x86_64, verify steps as following

1.prepare a shutoff vm

# virsh list --all
 Id    Name                           State
----------------------------------------------------
 -     7.0                            shut off

2.Excute the following command with the shutoff guest, every command could get the expect error
# virsh domtime 7.0 --time 123
error: Requested operation is not valid: domain is not running

# virsh domtime 7.0 --sync
error: Requested operation is not valid: domain is not running

# virsh domtime 7.0 --now
error: Requested operation is not valid: domain is not running

# virsh domtime 7.0 --pretty
error: Requested operation is not valid: domain is not running

According to the upper steps, mark this bug verified

Comment 7 errata-xmlrpc 2015-11-19 05:53:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2202.html


Note You need to log in before you can comment on or make changes to this bug.