Bug 1147936 - group members returned in lowercase with case_sensitive=preserving
Summary: group members returned in lowercase with case_sensitive=preserving
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jakub Hrozek
QA Contact: Kaushik Banerjee
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-30 11:07 UTC by Kaushik Banerjee
Modified: 2020-05-02 17:49 UTC (History)
7 users (show)

Fixed In Version: sssd-1.12.1-3.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 10:33:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github SSSD sssd issues 3495 0 None closed group members returned in lowercase with case_sensitive=preserving 2020-07-02 12:56:50 UTC
Red Hat Product Errata RHBA-2015:0441 0 normal SHIPPED_LIVE sssd bug fix and enhancement update 2015-03-05 15:05:27 UTC

Description Kaushik Banerjee 2014-09-30 11:07:26 UTC
Description of problem:
group members are returned in lowercase with case_sensitive=preserving

Version-Release number of selected component (if applicable):
sssd-1.12.1-2.el7

How reproducible:
Always

Steps to Reproduce:
1. Add the following user and group to ldap server
dn: cn=User_CS1_grp1,ou=Groups,dc=example,dc=com
objectClass: posixGroup
memberUid: User_CS1
cn: User_CS1_grp1_Alias
cn: User_CS1_grp1
gidNumber: 304560

dn: uid=User_CS1,ou=Users,dc=example,dc=com
objectClass: posixAccount
objectClass: account
cn: User_CS1
homeDirectory: /home/User_CS1
userPassword:: XXXXX
uid: User_CS1_Alias
uid: User_CS1
uidNumber: 304560
gidNumber: 304560

2. Set case_sensitive=preserving in domain section of sssd.conf

3. Lookup group
# getent group user_cs1_grp1
User_CS1_grp1:*:304560:user_cs1

# getent group User_CS1_grp1
User_CS1_grp1:*:304560:user_cs1


Actual results:
The case is converted to lowercase for group members

Expected results:
Case should be preserved for group members too.

Additional info:
id lookup of user shows group names with preserved cases.
# id user_cs1
uid=304560(User_CS1) gid=304560(User_CS1_grp1) groups=304560(User_CS1_grp1)

# id User_CS1
uid=304560(User_CS1) gid=304560(User_CS1_grp1) groups=304560(User_CS1_grp1)

Comment 2 Jakub Hrozek 2014-09-30 14:21:54 UTC
Michal, can you look at this one as well?

Comment 3 Michal Zidek 2014-10-01 11:10:26 UTC
We pass wrong parameter to sss_get_cased_name when getting group members (case_sensitive instead of case_preserve). Will send patch soon.

Comment 4 Jakub Hrozek 2014-10-01 13:22:20 UTC
(In reply to Michal Zidek from comment #3)
> We pass wrong parameter to sss_get_cased_name when getting group members
> (case_sensitive instead of case_preserve). Will send patch soon.

Thanks, cloning!

Comment 5 Jakub Hrozek 2014-10-01 13:23:14 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/2453

Comment 6 Jakub Hrozek 2014-10-01 17:31:53 UTC
* master: f6e008fe677ffcf8781c1d5154544066ea7ca9d4

Comment 8 Kaushik Banerjee 2014-12-03 09:43:21 UTC
Verified in version 1.12.2-28.el7

# getent group User_CS1_grp1
User_CS1_grp1_Alias:*:304560:User_CS1

Comment 10 errata-xmlrpc 2015-03-05 10:33:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0441.html


Note You need to log in before you can comment on or make changes to this bug.