Bug 114804 - XFree86-SDK does not include the header files needed to build the XFree86 Synaptics driver
XFree86-SDK does not include the header files needed to build the XFree86 Syn...
Status: CLOSED DUPLICATE of bug 99351
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-02 19:32 EST by Paul Bender
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vnc+synaptic patch fix (1.14 KB, text/plain)
2004-02-02 19:32 EST, Paul Bender
no flags Details

  None (edit)
Description Paul Bender 2004-02-02 19:32:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
I downloaded and built the XFree86 Synaptics Touchpad driver from
<http://w1.894.telia.com/~u89404340/touchpad/files/synaptics-0.12.3.tar.bz2>.
I noticed from my XFree86 logs that it was being built against Xfree86
4.2.0, which I thought was odd. Further digging revealed that the
driver included its own version of the XFree86 SDK headers files in
its build tree.

Apparently, this is because the default XFree86 4.3.0 does not include
all the XFree86 SDK header files needed to build the Synaptics driver.

Still further investigation revealed that the
XFree86-4.3.0-45.0.1.src.rpm contains a patch that is supposed to fix
the problem
(XFree86-4.3.0-SDK-add-missing-includes-for-vnc-and-synaptics.patch).
However, the patch is not being applied. I assume that this is because
patch no longer works.

The patch no longer works because it tries to include a header file
that appears to no longer exist (exevent.h). However, the Synaptics
driver does not appear to need this file because the function
prototypes it uses  from this header file are now found in a different
header file (xf86Xinput.h).

Once I fixed the vnc+synaptic patch in the XFree86 source RPM,
modified the RPM's spec file to apply the fixed vnc+synaptic patch
rather than the vnc patch and rebuilt the RPM, I was able to build the
Synaptics driver against the header files installed by the SDK RPM
(after some modifications to the driver's Makefile and synaptics.c files).

It would be nice if this could be the default for the XFree86 RPM.

In case it is of any help, I will attach a diff between the original
vnc+synaptic patch and the fixed vnc+synaptic patch.

Version-Release number of selected component (if applicable):
4.3.0-45.0.1

How reproducible:
Always

Steps to Reproduce:

    

Additional info:
Comment 1 Paul Bender 2004-02-02 19:32:46 EST
Created attachment 97425 [details]
vnc+synaptic patch fix
Comment 2 Aleksey Nogin 2004-02-18 01:12:02 EST
Is your working driver available for downloade somewhere? Thanks!
Comment 3 Mike A. Harris 2004-02-18 01:25:47 EST

*** This bug has been marked as a duplicate of 99351 ***
Comment 4 Paul Bender 2004-02-19 11:11:19 EST
I provided my synaptics driver modifications to the maintainer. With
these modifications, the driver will build against the system XFree86
headers if they are available. Otherwise, the driver will build
against its local copy. The driver available at
<http://w1.894.telia.com/~u89404340/touchpad/> now contains these
modifications.
Comment 5 Red Hat Bugzilla 2006-02-21 14:01:04 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.