Bug 1148062 - attribute error on booleanRecords.modify: no attribute 'load'
Summary: attribute error on booleanRecords.modify: no attribute 'load'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: policycoreutils
Version: 6.6
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Miroslav Grepl
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks: 1148800
TreeView+ depends on / blocked
 
Reported: 2014-09-30 15:43 UTC by Mooli Tayer
Modified: 2015-07-22 07:03 UTC (History)
15 users (show)

Fixed In Version: policycoreutils-2.0.83-19.48.el6
Doc Type: Bug Fix
Doc Text:
A new "noreload" option was implemented for semanage commands in Red Hat Enterprise Linux 6.6. However, due to a missing reload initialization in the semanageRecords() function, users could not enable Booleans directly using the seobject python module that comes from the policycoreutils-python utility. This bug has been fixed, and users can now set Booleans correctly using the seobject python module.
Clone Of:
: 1148800 (view as bug list)
Environment:
Last Closed: 2015-07-22 07:03:58 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1360 normal SHIPPED_LIVE policycoreutils bug fix update 2015-07-20 17:59:22 UTC

Description Mooli Tayer 2014-09-30 15:43:41 UTC
Description of problem:

attribute error when calling seobject.booleanRecords().modify()
with on/off

Version-Release number of selected component (if applicable):

How reproducible:

100%

Steps to Reproduce:

on rhel 6.6 with policycoreutils-python-2.0.83-19.47.el6.x86_64 and
libsemanage-python-2.0.43-4.2.el6.x86_64

python
>>> import seobject
>>> seobject.booleanRecords().modify('virt_use_samba','on')

(The same with any other boolean and with off)
Actual results:

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib64/python2.6/site-packages/seobject.py", line 2102, in modify
    self.commit()
  File "/usr/lib64/python2.6/site-packages/seobject.py", line 309, in commit
    semanage_set_reload(self.sh, self.load) 
AttributeError: booleanRecords instance has no attribute 'load'


Expected results:

Should set boolean.

Additional info:

libselinux-2.0.94-5.8.el6.x86_64
libselinux-utils-2.0.94-5.8.el6.x86_64
selinux-policy-targeted-3.7.19-260.el6.noarch
libselinux-python-2.0.94-5.8.el6.x86_64
selinux-policy-3.7.19-260.el6.noarch

Comment 2 Milos Malik 2014-10-01 11:01:51 UTC
This is a regression. The reproducer works well on RHEL-6.5, but fails on RHEL-6.6.

Comment 16 errata-xmlrpc 2015-07-22 07:03:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1360.html


Note You need to log in before you can comment on or make changes to this bug.