Bug 1148087 - Fedora 21 Alpha ISO images fail to boot on some systems when written to optical media (boot stops or reboots after ISOLINUX string displayed)
Summary: Fedora 21 Alpha ISO images fail to boot on some systems when written to optic...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: syslinux
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: https://fedoraproject.org/wiki/Common...
Depends On:
Blocks: F21BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2014-09-30 16:31 UTC by Adam Williamson
Modified: 2014-10-15 20:38 UTC (History)
9 users (show)

Fixed In Version: syslinux-6.03-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-12 13:56:04 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1141496 None None None Never

Internal Links: 1141496

Description Adam Williamson 2014-09-30 16:31:50 UTC
Splitting out from #1141496 as it seems the issue Jon Ingason and I saw is not quite the same one Joachim Backes sees.

For me and Jon, on two systems for Jon and one for me, boot of Fedora 21 Alpha images (I'm testing x86-64 Server netinst) fails when written to an optical disc (I'm using DVD-R media).

The boot displays the ISOLINUX string very briefly - 'ISOLINUX 6.02' and then a copyright/credit message that's visible for only a split second, for me - then either reboots (me, one of Jon's systems) or hangs/stops (Jon's other system).

For me this occurs whether the disc is written with nautilus or cdrecord.

The same image written to a USB stick boots successfully.

My test system is a Sony Vaio Z (2010 VPC-Z11 model), Insyde H20 firmware. Jon is testing with an HP Compaq DC5850 (which boot loops) and a Dell Dimension 3100 (which stops after displaying 'ISOLINUX 6.02', Jon did not specify whether he sees the credit message).

pjones reports that the same image boots successfully for him when written with cdrecord on a Intel Desktop Board DQ67SK with InsydeH2O firmware "SBM.  03.72.24" or a "hp ultrabook 6930p with some random test firmware".

Comment 1 Jon Ingason 2014-09-30 16:51:39 UTC
I didn't see any copyright/credit message on either system.

Comment 2 satellitgo 2014-10-03 12:19:36 UTC
DVD/CD install to bare metal (usb HD) worked for me on Fedora-Live-Workstation-x86_64-21_Beta-TC1.iso  and Fedora-Live-SoaS-x86_64-21_Beta-TC1.iso

MSI windbook bios boot

Comment 3 Adam Williamson 2014-10-03 18:09:15 UTC
Discussed at 2014-10-03 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2014-10-03/f21-blocker-review.2014-10-03-15.58.log.txt . For now accepted as a blocker as it clearly violates the criterion "All release-blocking images must boot in their supported configurations." for affected systems, but we still aren't sure how common this bug is. It would  help to have more testing; I'm going to send a call for testing out to multiple lists later today.

Comment 4 Jon Ingason 2014-10-04 12:21:09 UTC
I have now test Fedora-Server-netinst-x86_64-21_Beta_TC1.iso with same result as before. But I have also boot it on my ASUS X501U laptop (runing Windows 8.1) and it came to installation menu. Since I was not going to install Fedora on that laptop I stopped there. So the booting was ok.

Comment 5 Mike Ruckman 2014-10-08 16:37:29 UTC
Same result on Fedora-Server-netinst-x86_64_Beta_TC2.

Comment 6 Adam Williamson 2014-10-09 01:33:48 UTC
syslinux 6.03 appears to fix this for me. I built three test live images:

#1 with syslinux 6.02-7.fc21 on the build host *and* in the package set used to build the live image
#2 with syslinux 6.03-1.fc22 on the build host but syslinux 6.02-7.fc21 in the package set used to build the live image
#3 with syslinux 6.03-1.fc22 on the build host*and* in the package set used to build the live image

#1 and #2 fail to boot on my test system. #3 boots.

Comment 7 Jan Sedlák 2014-10-09 12:25:28 UTC
I have tested Fedora-Server-netinst-x86_64-21_Beta_TC2 and Fedora-Workstation-netinst-x86_64-21_Beta_TC2 burned to DVD-RW with Brasero on three machines - with MSI Z77A-G45 Gaming motherboard, Intel AAD41691-207 and ASUS M5A97 Pro and all of them booted without problem.

Comment 8 Fedora Update System 2014-10-09 19:03:45 UTC
syslinux-6.03-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/syslinux-6.03-1.fc21

Comment 9 Fedora Update System 2014-10-10 16:09:55 UTC
Package syslinux-6.03-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing syslinux-6.03-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-12580/syslinux-6.03-1.fc21
then log in and leave karma (feedback).

Comment 10 Jon Ingason 2014-10-11 15:12:51 UTC
I have now tried Fedora-Server-netinst-x86_64-21_Beta_TC2.iso with same results as previous tests.
Now Fedora-Server-netinst-x86_64-21_Beta_TC3.iso is available so I downloaded it and tested with successful results, i.e. I can boot my both machines from it. I just need to exchange the disks to install F21-Beta. But that should not be a problem.

Comment 11 Fedora Update System 2014-10-12 13:56:04 UTC
syslinux-6.03-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Adam Williamson 2014-10-15 20:38:36 UTC
Jon: yup, I had the same experience. Thanks for confirming the fix!


Note You need to log in before you can comment on or make changes to this bug.