Bug 1148113 - sssd-ldap man page changes, add 'access_provider = ldap' as a requirement 'ldap_access_order = for lockout'
Summary: sssd-ldap man page changes, add 'access_provider = ldap' as a requirement 'ld...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd
Version: 6.6
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jakub Hrozek
QA Contact: Kaushik Banerjee
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-30 18:21 UTC by Dan Lavu
Modified: 2020-05-02 17:49 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Do not document.
Clone Of:
Environment:
Last Closed: 2015-07-22 06:41:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github SSSD sssd issues 3493 0 None None None 2020-05-02 17:49:25 UTC
Red Hat Product Errata RHBA-2015:1448 0 normal SHIPPED_LIVE sssd bug fix and enhancement update 2015-07-20 18:43:53 UTC

Description Dan Lavu 2014-09-30 18:21:47 UTC
Description of problem:
The man page for sssd-ldap is unclear about the configuration requirements to use the 'ldap_access_order = lockout' feature.

When using 'ldap_access_order = lockout', the configuration *must* contain 'access_provider = ldap' otherwise this will not work. We wish to improve the text to make this absolutely clear.  


Version-Release number of selected component (if applicable):
All versions

How reproducible:


Steps to Reproduce:
1. N/A
2.
3.

Actual results:
N/A

Expected results:
N/A

Additional info:

Will submit a man page patch soon.

Comment 1 Dan Lavu 2014-09-30 18:22:51 UTC
Forgot, the original ticket in regards to this RFE is https://bugzilla.redhat.com/show_bug.cgi?id=1099290

Comment 3 Jakub Hrozek 2014-09-30 19:11:09 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/2451

Comment 4 Jakub Hrozek 2014-10-22 19:48:20 UTC
* master: 03b02ec99ea4be8e6f41c70dbe91d7175d5b63ea

Comment 7 Kaushik Banerjee 2015-03-30 10:50:15 UTC
Verified in sssd-1.12.4-25.el6

The additional text in the manpage now has:
Please note that ´access_provider = ldap´ must be set for this feature to work.

Comment 9 errata-xmlrpc 2015-07-22 06:41:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1448.html


Note You need to log in before you can comment on or make changes to this bug.