Bug 1148189 - rubygem-staypuft: "service network restart" line in the %post section of the kickstart prevents subsequent packages installation/update on some setups.
Summary: rubygem-staypuft: "service network restart" line in the %post section of the...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhel-osp-installer
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: z2
: Installer
Assignee: Brad P. Crochet
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-30 21:43 UTC by Alexander Chuzhoy
Modified: 2014-11-04 17:02 UTC (History)
7 users (show)

Fixed In Version: rhel-osp-installer-0.4.2-1.el6ost
Doc Type: Bug Fix
Doc Text:
A provisioning snippet in the Red Hat Enterprise Linux OpenStack Installer included a step to restart the network during a kickstart. This made it possible for an interface to be unavailable while it was still needed. This update removes the step, thereby ensuring that all networkign interfaces are available during the kickstart.
Clone Of:
Environment:
Last Closed: 2014-11-04 17:02:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description Alexander Chuzhoy 2014-09-30 21:43:35 UTC
rubygem-staypuft:  "service network restart" line in the %post section of the kickstart prevents subsequent packages installation/update on some setups.

Environment:
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-foreman-installer-2.0.26-1.el6ost.noarch
rhel-osp-installer-0.3.6-1.el6ost.noarch
openstack-puppet-modules-2014.1-21.8.el6ost.noarch

Steps to reproduce:
1. install rhel-osp-installer.
2. Configure/run HAneutron deployment+gre

Result:
The deployment gets stuck on 60% installing the controllers. 
Checking the controllers - the puppet wasn't installed.
Checking the installation log - the rhos-release package wasn't installed.

*Note: intermittently - it worked (sometimes on 1-2 controllers out of 3), but in most cases it didn't. Commenting out the "service network restart" line in the post section of the kickstart seems to resolve the issue.

Expected result:
The deployment should complete with no issues.

Comment 2 Mike Burns 2014-10-01 11:42:37 UTC
Correct PR:

https://github.com/theforeman/foreman-installer-staypuft/pull/97

Comment 4 Alexander Chuzhoy 2014-10-10 13:21:44 UTC
Verified: rhel-osp-installer-0.4.2-1.el6ost.noarch


The line was removed and the reported issue doesn't reproduce.

Comment 8 errata-xmlrpc 2014-11-04 17:02:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.