Bug 114827 - Kernel will panic after init 6
Summary: Kernel will panic after init 6
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-netboot
Version: 3.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-03 10:20 UTC by Risto Sainio
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2005-08-01 19:58:15 UTC


Attachments (Terms of Use)

Description Risto Sainio 2004-02-03 10:20:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20021204

Description of problem:
The file /usr/share/redhat-config-netboot/diskless/disklessrc calls at
the very end 'exec /sbin/init --init'. The problem is that during init
6  the init will started exit and the kernel will continue the as if
the linuxrc has just ended. This will  lead into kernel-panic as the
kernel tries to mount root-filesystem.
It would be better to use "echo 0x100 > real-root-dev"

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install netboot
2.netboot
3.check your console
    

Additional info:

Comment 1 Daniel Walsh 2004-04-28 20:52:02 UTC
I don't understand what this will do?   Or what you mean?

Could you sens me a patch to change disklessrc?



Comment 2 Nils Philippsen 2004-04-30 12:30:31 UTC
He probably means that rather than running "exec /sbin/init --init"
from linuxrc, we should rather go along with the "standard" routine
like in a normal initrd, i.e. setting up everything, "echo 0x100 >
/proc/sys/kernel/real-root-dev", pivot_root(), then exit which will
start /sbin/init from the kernel rather than from the initrd.

Comment 3 Jason Vas Dias 2005-08-01 19:58:15 UTC
This bug is now fixed in all latest versions of {system,redhat}-config-netboot.



Note You need to log in before you can comment on or make changes to this bug.