Bug 114830 - On Tomcat 4.1 the public item view never changes after the first viewing
Summary: On Tomcat 4.1 the public item view never changes after the first viewing
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other
Version: nightly
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: ccm-bugs-list
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 113496
TreeView+ depends on / blocked
 
Reported: 2004-02-03 13:00 UTC by Daniel Berrange
Modified: 2007-04-18 17:02 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2004-02-05 14:53:23 UTC


Attachments (Terms of Use)

Description Daniel Berrange 2004-02-03 13:00:03 UTC
Description of problem:
If you view a published content item, then go and view the page for a
different item, it'll show the first item still. In fact no matter
which item you try to view it will always show the first one to be
viewed after server startup. This only happens on Tomcat 4.1. We have
similar problems viewing categories in London Navigation application.
Developer support shows that different queries are being run, but the
ultimate XML output for the page is always identical!!!!

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create and publish item 'foo'
2. Create and publish item 'bar
3. View item 'foo' - /content/foo.en
4. View item 'bar' - /content/bar.en
  
Actual results:
When viewing 'bar' it shows details for 'foo'

Expected results:
When viewing 'bar' it shows details for 'bar'

Additional info:

Comment 1 Jon Orris 2004-02-03 15:12:37 UTC
RC1 Blocker

Comment 2 Daniel Berrange 2004-02-03 16:01:04 UTC
It turns out that if you have a JSP tag

  <foo:bar>

Then, rather than creating the object corresponding to foo:bar on
every request, it is valid for the servlet container to keep a pool of
pre-created objects around. The bebop JSP ShowAll tag has a dubious
piece of code:

   if (m_inputDoc == null) {
        m_inputDoc = (com.arsdigita.xml.Document)pageContext.getRequest()
            .getAttribute(INPUT_DOC_ATTRIBUTE);
    }

Now since the Tag object can be cached, the effect this has is that
this tag object will always output the same XML! Tomcat 4.0 and Resin
don't  do JSP tag object caching, hence why we've not seen this
before. Resolver in p4 40010



Comment 3 Jon Orris 2004-02-05 14:53:23 UTC
Verified on 4.1.



Note You need to log in before you can comment on or make changes to this bug.