Bug 114832 - sigtrap when open new nautilus window
sigtrap when open new nautilus window
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ORBit2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-03 08:10 EST by Daniel Malmgren
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-07 13:20:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Malmgren 2004-02-03 08:10:20 EST
Description of problem:
For every new nautilus window I open I get a requester complaining
about a sigtrap.

Version-Release number of selected component (if applicable):
nautilus-2.5.6-1, glibc-2.3.3-7, glib2-2.3.2-1, ORBit2-2.9.6-1

How reproducible:
I think it's 100%, not quite sure there

Steps to Reproduce:
1. Start nautilus (from a terminal, double clicking a desktop icon, etc)
  
Actual results:
I get a requester saying: The program "nautilus" (process xxxx) has
crashed because of a major fault. (sigtrap)

(my own translation, my system is in swedish)
Except for the requester everything works fine.

Additional info:
Backtrace:
[~$] gdb nautilus
GNU gdb Red Hat Linux (6.0post-0.20031117.7rh)
Copyright 2003 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and
you are
welcome to change it and/or distribute copies of it under certain
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for
details.
This GDB was configured as "i386-redhat-linux-gnu"...Using host
libthread_db library "/lib/tls/libthread_db.so.1".
 
(gdb) run
Starting program: /usr/bin/nautilus
[Thread debugging using libthread_db enabled]
[New Thread 1091458496 (LWP 13541)]
 
(nautilus:13541): Gtk-WARNING **: Theme directory  of theme crystal
has no size field
 
[New Thread 1103547312 (LWP 13544)]
 
** ERROR **: file orbit-object.c: line 149 (do_unref): assertion
failed: (robj->refs < ORBIT_REFCOUNT_MAX && robj->refs > 0)
aborting...
 
Program received signal SIGTRAP, Trace/breakpoint trap.
[Switching to Thread 1091458496 (LWP 13541)]
0x40aafb30 in g_logv () from /usr/lib/libglib-2.0.so.0
(gdb) thread apply all bt
 
Thread 2 (Thread 1103547312 (LWP 13544)):
#0  0xffffe410 in ?? ()
#1  0x41c6c9a8 in ?? ()
#2  0xffffffff in ?? ()
#3  0x00000007 in ?? ()
#4  0x40cdf217 in poll () from /lib/tls/libc.so.6
#5  0x40aa94b6 in g_main_loop_get_context () from
/usr/lib/libglib-2.0.so.0
#6  0x40aa87f0 in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#7  0x40aa8fd1 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#8  0x40a00bf2 in link_thread_io_context () from /usr/lib/libORBit-2.so.0
#9  0x40ac085d in g_static_private_free () from /usr/lib/libglib-2.0.so.0
#10 0x404505fc in start_thread () from /lib/tls/libpthread.so.0
#11 0x40ce889a in clone () from /lib/tls/libc.so.6
 
Thread 1 (Thread 1091458496 (LWP 13541)):
#0  0x40aafb30 in g_logv () from /usr/lib/libglib-2.0.so.0
#1  0x40aafd84 in g_log () from /usr/lib/libglib-2.0.so.0
#2  0x409e5ab6 in ORBit_RootObject_duplicate_T () from
/usr/lib/libORBit-2.so.0
#3  0x409efc98 in CORBA_any__freekids () from /usr/lib/libORBit-2.so.0
#4  0x409ea9f8 in ORBit_policy_validate () from /usr/lib/libORBit-2.so.0
(gdb) quit
Comment 1 Alexander Larsson 2004-02-09 06:33:10 EST
seems like an orbit2 bug
Comment 2 Daniel Malmgren 2004-03-07 13:20:13 EST
Haven't seen this one in the last month. Guess it's gone in newer
nautilus/ORBit versions. Closing.

Note You need to log in before you can comment on or make changes to this bug.