Bug 1148408 - Do not refresh resource tree after scheduling operation
Summary: Do not refresh resource tree after scheduling operation
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: UI
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ER05
: JON 3.3.0
Assignee: Libor Zoubek
QA Contact: Armine Hovsepyan
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-01 12:04 UTC by Libor Zoubek
Modified: 2015-11-02 00:44 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-12-11 14:00:02 UTC


Attachments (Terms of Use)
resource_tree (177.01 KB, image/png)
2014-10-24 12:02 UTC, Armine Hovsepyan
no flags Details

Description Libor Zoubek 2014-10-01 12:04:01 UTC
Description of problem:

More or less usability issue. We always refresh left resource tree when an operation is scheduled

Version-Release number of selected component (if applicable):
JON 3.3.0.Er03

How reproducible: always


Steps to Reproduce:
1. have i.e. AS7 imported
2. navigate to it's platform
3. expand tree and select i.e. some datasource, naviage to it (now, your tree is exapnded)
4. now navigate to platform (tree is still exapnded)
5. schedule an operation on platform

Actual results:

tree refreshes and forgets how it was expanded, you have to expand it again in order to go back to datasources


Expected results:

resource tree does not need to be refreshed, thus your expanded nodes won't be lost, just because you've scheduled an operation.


Additional info:

Comment 2 Libor Zoubek 2014-10-07 13:35:31 UTC
branch:  master
link:    https://github.com/rhq-project/rhq/commit/7ad8338c7
time:    2014-10-07 15:35:07 +0200
commit:  7ad8338c7324b05b4227f598c2c75a379d38e515
author:  Libor Zoubek - lzoubek@redhat.com
message: Bug 1148408 - Do not refresh resource tree after scheduling operation

Comment 3 Thomas Segismont 2014-10-09 16:00:59 UTC
Cherry-picked over to release/jon3.3.x

commit 6271d2ae9fb98ef8c09eb1fb8f2421371c87582e
Author: Libor Zoubek <lzoubek@redhat.com>
Date:   Tue Oct 7 15:34:20 2014 +0200
    
    (cherry picked from commit 7ad8338c7324b05b4227f598c2c75a379d38e515)
    Signed-off-by: Thomas Segismont <tsegismo@redhat.com>

Comment 5 Simeon Pinder 2014-10-21 20:24:03 UTC
Moving to ON_QA as available to test with the latest brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=394734

Comment 6 Armine Hovsepyan 2014-10-24 12:02:59 UTC
Created attachment 950370 [details]
resource_tree

Comment 7 Armine Hovsepyan 2014-10-24 12:03:29 UTC
verified in JON 3.3 ER05 + FF18.0
Screen-shot attached.


Note You need to log in before you can comment on or make changes to this bug.