Bug 1148435 - Automated subscription-manager registration fails with special characters in password
Summary: Automated subscription-manager registration fails with special characters in ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhel-osp-installer
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: z2
: Installer
Assignee: Mike Burns
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-01 13:01 UTC by Rhys Oxenham
Modified: 2014-11-04 17:02 UTC (History)
7 users (show)

Fixed In Version: rhel-osp-installer-0.4.2-1.el6ost
Doc Type: Bug Fix
Doc Text:
A provisioning snippet in the Red Hat Enterprise Linux OpenStack Installer incorrectly used double quotes when specifying subscription-manager passwords. This prevented passwords with special characters from being parsed and validated correctly. With this update, the snippet now uses single quotes for subscription-manager passwords. This ensures that passwords are always parsed and validated correctly.
Clone Of:
Environment:
Last Closed: 2014-11-04 17:02:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description Rhys Oxenham 2014-10-01 13:01:14 UTC
Description of problem:

When using the redhat_register snipped in the default RHEL kickstart, the use of double quotes for the password entry can cause evaluation problems when a special character is in use in the password. As the password is not evaluated properly an 'Invalid Username/Password' error is displayed.

This has more serious consequences as the machine proceeds to reboot after a failed registration, updates are not applied, puppet is not installed, and the OpenStack packages are not installed/configured as required.

When the kickstart is manually edited to use single quotes, it allows both normal passwords and passwords with special characters to go through successfully. Suggest we implement a patch to set this or at the very least document this requirement.

Version-Release number of selected component (if applicable):

RHEL OSP 5.0 on RHEL 7.0
RHEL OSP Installer (Staypuft) GA3 (pre-A1)

How reproducible:

Every time.

Steps to Reproduce:
1. Install RHEL OSP Installer and set subscription manager details, using your password that contains special characters
2. Create an OpenStack deployment
3. Deploy your OpenStack environment and watch logs

Actual results:

Invalid Username/Password error message displayed, box reboots with no services installed, puppet included (as it's shipped in rhelosp5 channel).

Expected results:

Username/password parsed properly, system registered and required components installed.

Additional info:

As above, setting the kickstart to use single quotes gets around this problem and allows passwords containing special characters to go through too.

Comment 4 Alexander Chuzhoy 2014-10-15 13:35:07 UTC
Verified:
rhel-osp-installer-0.3.6-1.el6ost.noarch
openstack-foreman-installer-2.0.26-1.el6ost.noarch
openstack-puppet-modules-2014.1-21.8.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noar

Successfully registered a machine to cdn using a password with special chars and bearing in mind BZ #1070388

Comment 6 Mike Burns 2014-10-24 13:38:10 UTC
doc text looks correct to me, removing needinfo

Comment 8 errata-xmlrpc 2014-11-04 17:02:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.