Bug 114846 - postgresql-server should stop itself before uninstall
postgresql-server should stop itself before uninstall
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rh-postgresql (Show other bugs)
3.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Tom Lane
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-03 10:38 EST by Mario Lorenz
Modified: 2013-07-02 23:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-23 19:00:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mario Lorenz 2004-02-03 10:38:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2)
Gecko/20030708

Description of problem:
Uninstalling the postgresql server while it is running
will leave it running, yet erasing the executables, breaking
at least "service rhdb stop" (as the rhdb script obviously has gone)

I do not know what Red Hat's general policy on this matter is
(wheter a servicens hould be stopped before uninstall)
but net-snmp for example does contain code in the %preun script
to stop the server if it is running and the server is removed
(instead of upgraded).
To be consistent, and for plain convenience I suggest the same for
postgresql-server

I do not know what the implications are for "server clusters", when
several instances of postmaster run on the same host, but this
seems to be generally out of the scope of package management
(and severe breakage would ensure nevertheless, for the other
instances, as the server binaries and support files are gone)



Version-Release number of selected component (if applicable):
postgresql-server 7.3.4-9

How reproducible:
Always

Steps to Reproduce:
1. /sbin/service rhdb start
2. rpm --erase rh-postgresql-server
3. ps -axuww
    

Actual Results:  postmaster still running

Expected Results:  postmaster should have been stopped, as the
software is being removed
from the system

Additional info:
Comment 1 Suzanne Hillman 2004-02-06 15:27:26 EST
Internal RFE bug #115131 entered; will be considered for future releases.
Comment 2 Suzanne Hillman 2004-04-21 14:59:04 EDT
postgresql-server is not supported in RHEL3.
Comment 3 Mario Lorenz 2004-04-22 04:39:10 EDT
You are joking, right ?

This is rh-postgresql-server, available via RHN, in the standard RHEL3
channel.
NOTHING, NOWHERE, IS IT SAID THAT rh-postgresql-server IS NOT SUPPORTED.

Next time, you will be telling me glibc is not supported, or what?
Comment 4 Tom Lane 2004-06-23 19:00:42 EDT
Fixed in rh-postgresql 7.3.6-3 and postgresql 7.4.3-1.

Note You need to log in before you can comment on or make changes to this bug.