Bug 1148493 - Xorg.bin uses 100% CPU and X locks up when opening Firefox
Summary: Xorg.bin uses 100% CPU and X locks up when opening Firefox
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1159799 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-01 14:56 UTC by Jason Montleon
Modified: 2014-11-23 01:30 UTC (History)
9 users (show)

Fixed In Version: xorg-x11-drv-intel-2.99.916-3.20141117.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-18 12:13:38 UTC
Type: Bug


Attachments (Terms of Use)

Description Jason Montleon 2014-10-01 14:56:27 UTC
Description of problem:
I have a Lenovo T61 laptop with an Intel graphics card:
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (secondary) (rev 0c)

It seems to work fine, except that when I start up Firefox I can see (via ssh) that Xorg.bin consumes 100% CPU and the display locks up.

Version-Release number of selected component (if applicable):
[root@t61 ~]# rpm -q kernel xorg-x11-drv-intel firefox; uname -a
kernel-3.16.3-300.fc21.x86_64
kernel-3.16.3-302.fc21.x86_64
xorg-x11-drv-intel-2.99.916-2.fc21.x86_64
firefox-32.0.2-1.fc21.x86_64
Linux t61.montleon.intra 3.16.3-302.fc21.x86_64 #1 SMP Fri Sep 26 14:27:20 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:
Always on this system

Steps to Reproduce:
1. Install Fedora 21 on a T61 with Intel graphics
2. Run Firefox

Actual results:
Display locks up

Expected results:
Firefox opens normally

Additional info:
I can open firefox using fbdev.
cat /etc/X11/xorg.conf.d/10-device.conf 
Section "Device"
    Identifier "Configured Video Device"
    Driver "fbdev"
EndSection

Comment 1 Lubomir Rintel 2014-10-02 19:02:46 UTC
"Me too" -- the same hardware:

[root@odvarok lkundrak]# strace -ttt -f -p `pidof Xorg.bin` 2>&1 |head -n20
Process 683 attached with 2 threads
[pid   696] 1412275924.737825 futex(0x1b502b4, FUTEX_WAIT_PRIVATE, 1491, NULL <unfinished ...>
[pid   683] 1412275924.737901 ioctl(10, 0x40406469, 0x7fffe579baf0) = 0
[pid   683] 1412275924.739436 ioctl(10, 0xc0086457, 0x7fffe579baa0) = 0
[pid   683] 1412275924.739786 ioctl(10, 0x4020645d, 0x7fffe579ba80) = 0
[pid   683] 1412275924.740172 ioctl(10, 0x40406469, 0x7fffe579baf0) = 0
[pid   683] 1412275924.740914 ioctl(10, 0xc0086457, 0x7fffe579baa0) = 0
[pid   683] 1412275924.741334 --- SIGALRM {si_signo=SIGALRM, si_code=SI_KERNEL} ---
[pid   683] 1412275924.741633 rt_sigreturn() = 0
[pid   683] 1412275924.742020 ioctl(10, 0x4020645d, 0x7fffe579ba80) = 0
[pid   683] 1412275924.742421 ioctl(10, 0x40406469, 0x7fffe579baf0) = 0
[pid   683] 1412275924.742934 ioctl(10, 0xc0086457, 0x7fffe579baa0) = 0
[pid   683] 1412275924.743611 ioctl(10, 0x4020645d, 0x7fffe579ba80) = 0
[pid   683] 1412275924.743958 ioctl(10, 0x40406469, 0x7fffe579baf0) = 0
[pid   683] 1412275924.744372 ioctl(10, 0xc0086457, 0x7fffe579baa0) = 0
[pid   683] 1412275924.744803 ioctl(10, 0x4020645d, 0x7fffe579ba80) = 0
[pid   683] 1412275924.745167 ioctl(10, 0x40406469, 0x7fffe579baf0) = 0
[pid   683] 1412275924.745534 ioctl(10, 0xc0086457, 0x7fffe579baa0) = 0
[pid   683] 1412275924.745951 --- SIGALRM {si_signo=SIGALRM, si_code=SI_KERNEL} ---
[pid   683] 1412275924.746452 rt_sigreturn() = 0
[root@odvarok lkundrak]# 

(gdb) bt
#0  0x00007f14ccc85957 in ioctl () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f14c8410d6c in do_ioctl (fd=10, req=req@entry=1077961833, arg=arg@entry=0x7fffe579baf0)
    at kgem.c:212
#2  0x00007f14c84194bb in do_execbuf (execbuf=0x7fffe579baf0, kgem=0x7f14cf081000) at kgem.c:3209
#3  _kgem_submit (kgem=0x7f14cf081000) at kgem.c:3308
#4  0x00007f14c84693ad in sna_read_boxes (sna=0xa, dst=0x40406469, src_bo=0x7fffe579baf0, 
    box=0xffffffffffffffff, nbox=-1) at sna_io.c:594
#5  0x00007f14c842c5eb in _sna_pixmap_move_to_cpu (pixmap=0x1fe9a00, flags=34) at sna_accel.c:2364
#6  0x00007f14c842feb6 in sna_drawable_move_region_to_cpu (drawable=0x0, region=0x7fffe579c050, flags=65)
    at sna_accel.c:2757
#7  0x00007f14c8433899 in sna_get_image (drawable=0xa, x=0, y=-821555200, w=-1, h=-1, format=0, 
    mask=4294967295, dst=0x261da60 "") at sna_accel.c:16887
#8  0x0000000000588298 in miSpriteGetImage (pDrawable=0x1fe9a00, sx=0, sy=0, w=300, h=54, format=2, 
    planemask=4294967295, pdstLine=0x261da60 "") at misprite.c:405
#9  0x00000000004c8e8a in compGetImage (pDrawable=0x1fe9a00, sx=<optimized out>, sy=<optimized out>, 
    w=<optimized out>, h=<optimized out>, format=<optimized out>, planemask=4294967295, pdstLine=0x261da60 "")
    at compinit.c:148
#10 0x000000000043618b in DoGetImage (planemask=<optimized out>, height=<optimized out>, 
    width=<optimized out>, y=<optimized out>, x=<optimized out>, drawable=<optimized out>, 
    format=<optimized out>, client=<optimized out>) at dispatch.c:2118
#11 ProcGetImage (client=0x210e280) at dispatch.c:2181
#12 0x0000000000438fe7 in Dispatch () at dispatch.c:432
#13 0x000000000043d176 in dix_main (argc=16, argv=0x7fffe579c3d8, envp=<optimized out>) at main.c:296
#14 0x00007f14ccbaefe0 in __libc_start_main (main=0x4275f0 <main>, argc=16, argv=0x7fffe579c3d8, 
    init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffe579c3c8)
    at libc-start.c:289
#15 0x000000000042761e in _start ()
(gdb)

Comment 2 Lubomir Rintel 2014-10-02 20:29:56 UTC
The problem disappeared for me when I updated to today's Git snapshot.

Maybe one of the later SNA fixes helped?

Comment 3 David J. Fiddes 2014-11-02 18:16:12 UTC
I'm seeing this hang too on my Asus P5E-VM HDMI based system which has G35 embedded graphics:

00:02.0 VGA compatible controller: Intel Corporation 82G35 Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation 82G35 Express Integrated Graphics Controller (rev 03)

I'm running the same set of packages apart from a newer version of Firefox:

kernel-3.16.6-203.fc20.x86_64
kernel-3.17.1-300.fc21.x86_64
kernel-3.17.2-300.fc21.x86_64
xorg-x11-drv-intel-2.99.916-2.fc21.x86_64
firefox-33.0-1.fc21.x86_64
Linux snowman.fiddes-enterprises.com 3.17.2-300.fc21.x86_64 #1 SMP Thu Oct 30 19:23:48 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Also forcing fbdev seems to give a working system. Prior to today (2014-11-02) the system ran F20 with no problems.

Comment 4 Roland Hermans 2014-11-16 12:49:37 UTC
Same problem here on my Pentium D 920 system which has G65 embedded graphics after upgrading from Fedora 20 to Fedora 21 beta. When the X server is locked it does not respond to any key presses but I can still move the mouse pointer. X server also locks with other applications like Thunderbird and xmms. I haven't seen any issues with GNOME Shell, GNOME Terminal and VNC. Running Firefox from within VNC session on localhost works fine.

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 82G965 Integrated Graphics Controller (rev 02)
$ cat /proc/cpuinfo | grep model\ name
model name	: Intel(R) Pentium(R) D CPU 2.80GHz
model name	: Intel(R) Pentium(R) D CPU 2.80GHz
$ uname -rv
3.17.2-300.fc21.x86_64 #1 SMP Thu Oct 30 19:23:48 UTC 2014
$ rpm -q kernel xorg-x11-server-common xorg-x11-drv-intel firefox
kernel-3.16.6-203.fc20.x86_64
kernel-3.16.7-200.fc20.x86_64
kernel-3.17.2-200.fc20.x86_64
kernel-3.17.2-300.fc21.x86_64
xorg-x11-server-common-1.16.1-1.fc21.x86_64
xorg-x11-drv-intel-2.99.916-2.fc21.x86_64
firefox-33.1-2.fc21.x86_64

Comment 5 Fedora Update System 2014-11-17 18:55:57 UTC
xorg-x11-drv-intel-2.99.916-3.20141117.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/xorg-x11-drv-intel-2.99.916-3.20141117.fc21

Comment 6 Roland Hermans 2014-11-17 22:22:00 UTC
No issues seen so far after upgrading to xorg-x11-drv-intel-2.99.916-3.20141117.fc21 (64-bit). For me the bug seems to be fixed with this update.

Comment 7 David J. Fiddes 2014-11-17 23:05:20 UTC
Update seems to fix my problems as well.

Comment 8 Fedora Update System 2014-11-18 12:13:38 UTC
xorg-x11-drv-intel-2.99.916-3.20141117.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 jiri vanek 2014-11-18 14:54:50 UTC
Not only firefox was causing this issue. Generally any "big app" eg eclipse, netbeans, more tabs in modori, KDE (with disabled effects!?!??!)... Thank you for fix!

Comment 10 Account closed by the user 2014-11-19 13:53:51 UTC
*** Bug 1159799 has been marked as a duplicate of this bug. ***

Comment 11 Matías Kreder 2014-11-23 01:30:12 UTC
In my t410 this update also fixed a bug where all the fonts were going crazy.

Comment 12 Matías Kreder 2014-11-23 01:30:44 UTC
https://delete.fedorapeople.org/bug/


Note You need to log in before you can comment on or make changes to this bug.