This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 114851 - Remove the 'htmlview' dependancy from all documentation RPMs
Remove the 'htmlview' dependancy from all documentation RPMs
Status: CLOSED RAWHIDE
Product: Red Hat Web Application Framework
Classification: Retired
Component: documentation (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dennis Gregorovic
Jon Orris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-03 11:43 EST by Daniel Berrange
Modified: 2007-04-18 13:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-03 20:21:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2004-02-03 11:43:44 EST
Description of problem:
The DocBoook HTML RPMs all contain a dependancy on the 'htmlview'
program. This prevents installation of the manuals on anything other
than Red Hat distributions. The dependancy is completely bogus in any
case, since there are any number of HTML viewers that a user may
choose to read our documentation with.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Vadim Nasardinov 2004-02-03 11:53:35 EST
Funny, I didn't even know I had it:

|$ rpm --query --whatprovides htmlview
|htmlview-2.0.0-11
|$ rpm -ql htmlview
|/usr/bin/htmlview
|/usr/share/applications/redhat-web.desktop
|$ file /usr/bin/htmlview
|/usr/bin/htmlview: a /bin/bash script text executable
|$ rpm --query --whatrequires htmlview | sort
|cups-1.1.19-13
|gaim-0.71-2
|gnome-libs-1.4.1.2.90-35
|redhat-config-users-1.2.4-1
|redhat-logviewer-0.9.3-6
|xpdf-2.03-1
Comment 2 Dennis Gregorovic 2004-02-03 20:21:04 EST
@40028

Note You need to log in before you can comment on or make changes to this bug.