Bug 1148513 - CryptoError: luks_format failed for '/dev/md/pv00'
Summary: CryptoError: luks_format failed for '/dev/md/pv00'
Keywords:
Status: CLOSED DUPLICATE of bug 1160289
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 21
Hardware: ppc64le
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:c545365de2887eb672e514c91e3...
Depends On:
Blocks: F21PPCBeta
TreeView+ depends on / blocked
 
Reported: 2014-10-01 15:39 UTC by Mark Hamzy
Modified: 2014-11-06 21:03 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-06 21:03:02 UTC


Attachments (Terms of Use)
File: anaconda-tb (870.58 KB, text/plain)
2014-10-01 15:39 UTC, Mark Hamzy
no flags Details
File: anaconda.log (29.04 KB, text/plain)
2014-10-01 15:39 UTC, Mark Hamzy
no flags Details
File: environ (459 bytes, text/plain)
2014-10-01 15:39 UTC, Mark Hamzy
no flags Details
File: lsblk_output (2.63 KB, text/plain)
2014-10-01 15:39 UTC, Mark Hamzy
no flags Details
File: nmcli_dev_list (1.23 KB, text/plain)
2014-10-01 15:39 UTC, Mark Hamzy
no flags Details
File: os_info (377 bytes, text/plain)
2014-10-01 15:39 UTC, Mark Hamzy
no flags Details
File: program.log (36.40 KB, text/plain)
2014-10-01 15:39 UTC, Mark Hamzy
no flags Details
File: storage.log (606.87 KB, text/plain)
2014-10-01 15:39 UTC, Mark Hamzy
no flags Details
File: syslog (40.96 KB, text/plain)
2014-10-01 15:39 UTC, Mark Hamzy
no flags Details
File: ifcfg.log (1.60 KB, text/plain)
2014-10-01 15:39 UTC, Mark Hamzy
no flags Details
File: packaging.log (97.73 KB, text/plain)
2014-10-01 15:39 UTC, Mark Hamzy
no flags Details

Description Mark Hamzy 2014-10-01 15:39:31 UTC
Description of problem:
Selected three disks. Selected encryption and custom partitioning. Reclaimed all space on every disk. Automatic LVM creation. Modified LVM to RAID5. 

Version-Release number of selected component:
anaconda-21.48.6-1

The following was filed automatically by anaconda:
anaconda 21.48.6-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devicelibs/crypto.py", line 93, in luks_format
    raise CryptoError("luks_format failed for '%s'" % device)
  File "/usr/lib/python2.7/site-packages/blivet/formats/luks.py", line 230, in create
    key_size=self.key_size)
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 554, in execute
    options=self.device.formatArgs)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 354, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 354, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 214, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 178, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)
CryptoError: luks_format failed for '/dev/md/pv00'

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/ppc/ppc64/vmlinuz inst.vnc inst.sshd ip=9.5.178.25::9.5.178.1:255.255.255.0:ppc64lehamzytest2.rch.stglabs.ibm.com:eth0:none nameserver=9.5.175.8 bootdev=eth0
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.16.2-301.fc21.ppc64le
product:        Fedora"
release:        Cannot get release name.
type:           anaconda
version:        Fedora

Potential duplicate: bug 1040691

Comment 1 Mark Hamzy 2014-10-01 15:39:34 UTC
Created attachment 943106 [details]
File: anaconda-tb

Comment 2 Mark Hamzy 2014-10-01 15:39:35 UTC
Created attachment 943107 [details]
File: anaconda.log

Comment 3 Mark Hamzy 2014-10-01 15:39:36 UTC
Created attachment 943108 [details]
File: environ

Comment 4 Mark Hamzy 2014-10-01 15:39:37 UTC
Created attachment 943109 [details]
File: lsblk_output

Comment 5 Mark Hamzy 2014-10-01 15:39:38 UTC
Created attachment 943110 [details]
File: nmcli_dev_list

Comment 6 Mark Hamzy 2014-10-01 15:39:38 UTC
Created attachment 943111 [details]
File: os_info

Comment 7 Mark Hamzy 2014-10-01 15:39:39 UTC
Created attachment 943112 [details]
File: program.log

Comment 8 Mark Hamzy 2014-10-01 15:39:42 UTC
Created attachment 943113 [details]
File: storage.log

Comment 9 Mark Hamzy 2014-10-01 15:39:43 UTC
Created attachment 943114 [details]
File: syslog

Comment 10 Mark Hamzy 2014-10-01 15:39:43 UTC
Created attachment 943115 [details]
File: ifcfg.log

Comment 11 Mark Hamzy 2014-10-01 15:39:44 UTC
Created attachment 943116 [details]
File: packaging.log

Comment 12 Dan Horák 2014-11-06 21:03:02 UTC

*** This bug has been marked as a duplicate of bug 1160289 ***


Note You need to log in before you can comment on or make changes to this bug.