Bug 114868 - illogical name for Postfix sysconfig file
illogical name for Postfix sysconfig file
Status: CLOSED DUPLICATE of bug 113975
Product: Fedora
Classification: Fedora
Component: postfix (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-03 14:26 EST by Florin Andrei
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florin Andrei 2004-02-03 14:26:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040116

Description of problem:
The sysconfig file for the Postfix package is called
/etc/sysconfig/saslauthd. That is illogic; when looking at the
directory, one is led to believe that the file belongs somehow to the
cyrus-sasl package.
Not only that, but installing an updated version of cyrus-sasl from a
3rd party RPMs repository, which happens to use the logical name for
its sysconfig file (/etc/sysconfig/saslauthd) fails because of the
conflict with postfix. Example: http://www.invoca.ch/pub/packages/ the
site is maintained by Simon Matter, and provides RPM packages for
Cyrus IMAPd.

Version-Release number of selected component (if applicable):
postfix-2.0.11-5

How reproducible:
Always

Steps to Reproduce:
1.install the cyrus-sasl package by Simon Matter
2.
3.
    

Actual Results:  rpm fails due to conflict with postfix

Expected Results:  rpm should install the package

Additional info:

The sysconfig file for postfix should be called /etc/sysconfig/postfix
Comment 1 John Dennis 2004-02-03 14:46:18 EST
There is a cross dependency between cyrus-sals and postfix. Postfix
does indeed use /etc/sysconfig/saslauthd. The problem you are running
into is multiple packages might rely on this file and its contents, in
fact any non-root installed process which needs to perform SASL
authentication. At the moment I'm not aware of any mechanism in SASL
to selectively pick the authentication method based on the client.
Therefore all clients must agree. Since sasl authentcation is part of
imap the imap package installs this file, is that any more wrong than
postfix installing it? By the same logic suggested in the bug report
the file should have been called /etc/sysconfig/imap, but that is
non-sensical because the config file belongs to saslauthd and
saslauthd wouldn't find it. What is really needed is
/etc/sysconfig/saslauthd.d with config files for each client. But like
I said, saslauthd does not support per client configuration.

So what we really have is is the question of whether ANY package that
uses saslauthd should install its config file. Maybe not, since there
is a clearly a conflict, perhaps its best if no package ever installs
this file because its shared, then make the sysadmin read the install
doc and create it themselves. My primary concern with this is how few
sysadmins will actually do that.

I suspose the right answer is to have our cyrus-sasl package install
this file, which it currently does not, this to some degree is a
duplicate of bug #113975. I've added Nalin on the CC list for this bug. 

Question: Nalin, shouldn't our cyrus-sasl RPM install and own the
salsuathd config file? 

*** This bug has been marked as a duplicate of 113975 ***
Comment 2 John Dennis 2004-02-03 14:47:33 EST
opps, meant to add Nalin to CC list.
Comment 3 Florin Andrei 2004-02-03 15:02:54 EST
No, the problem is most packages in /etc/sysconfig use filenames
derived from their own package name: prelink for prelink, kudzu for
kudzu, etc.
By observing this simple rule, namespace clashes are much less likely.
cyrus-sasl could use "cyrus-sasl" or "saslauthd" or whatever, no other
package would normally claim that.
If the postfix package installs a file in /etc/sysconfig, that file
should be called "postfix", regardless of what's inside. In fact, the
same file could be used for other Postfix-related settings. It's the
job of the postfix package scripts to derive whatever info they like
from that file.
If /etc/sysconfig/saslauthd belongs, from a logical perspective, to
sasl-related functions that are used by other apps, then that file
should be installed by cyrus-sasl not by postfix or whatever.
Comment 4 John Dennis 2004-02-03 15:16:21 EST
I think you may have missed the issue. Postfix is not reading this
file directly, it makes no sense for this file to be named postfix in
any sense. Rather a library that postfix links against is reading this
file, and as a matter of fact that library is cyrus-sasl. More than
one client can link against cyrus-sasl, imap is one example, would you
call this file "imap"? The issue is that any process that links
against cyrus-sasl will likely use this file. It was probably a
mistake for postfix to install it, rather relying on cyrus-sasl to
install it.

The file is called saslauthd because its owned and read by saslauthd,
the only real quesiton is who should be installing this file, I
believe the correct answer is cyrus-sasl and the name has to remain
saslauthd or it will not be found.

It still believe this is a duplicate of bug 113975.

*** This bug has been marked as a duplicate of 113975 ***
Comment 5 Florin Andrei 2004-02-03 16:20:37 EST
Then i agree. In fact, that was all i was asking for: sasl should
install that file, not postfix.
Thanks.
Comment 6 Red Hat Bugzilla 2006-02-21 14:01:04 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.