Bug 1148740 - Auto-set the indexLocalOnly flag from the directory provider
Summary: Auto-set the indexLocalOnly flag from the directory provider
Keywords:
Status: CLOSED DUPLICATE of bug 1148686
Alias: None
Product: JBoss Data Grid 6
Classification: JBoss
Component: Infinispan
Version: 6.3.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Tristan Tarrant
QA Contact: Martin Gencur
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-02 09:10 UTC by Radim Vansa
Modified: 2014-10-03 07:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-03 07:01:09 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker ISPN-4340 0 Major Reopened Automatically setup shared indexes when indexing is enabled 2015-09-11 14:09:38 UTC
Red Hat Issue Tracker ISPN-4584 0 Major Open Stricter validation of cache configurations for distributed indexes 2015-09-11 14:09:38 UTC

Description Radim Vansa 2014-10-02 09:10:39 UTC
The flag indexLocalOnly can be guessed based on the directory provider/index manager settings. Requiring this flag to be set by user opens a spot for misconfiguration.

Comment 1 Radim Vansa 2014-10-02 09:14:56 UTC
I would also recommend to include all supported configurations in the schema directly, instead of using property list.

Comment 3 Martin Gencur 2014-10-03 07:01:09 UTC
Marking as a duplicate of BZ1148686 as the other BZ contains more information including some discussions.

*** This bug has been marked as a duplicate of bug 1148686 ***


Note You need to log in before you can comment on or make changes to this bug.