Bug 114877 - Fonts on gdm graphical login screen are too small to read
Fonts on gdm graphical login screen are too small to read
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-03 16:53 EST by Keith Rice
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-22 01:45:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"Screen" sections from xorg.conf that does not produce error. (880 bytes, text/plain)
2004-06-28 03:10 EDT, Glen Shadbolt
no flags Details
Xorg log with tiny fonts. (46.58 KB, text/plain)
2004-06-28 03:17 EDT, Glen Shadbolt
no flags Details
Xorg log with normal fonts (46.65 KB, text/plain)
2004-06-28 03:18 EDT, Glen Shadbolt
no flags Details

  None (edit)
Description Keith Rice 2004-02-03 16:53:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
I just completed installing Fedora Core 1. When the system comes up 
in runlevel 5 the gdm graphical greeter screen is displayed. However, 
the fonts displayed (for username/password prompts, etc.) are 
extremely small and cannot be read. I logged in as root and ran 
gdmconfig and changed the local greeter to the standard greeter and 
the fonts are normal and readable. Howeverm the font problem remains 
when I change back to the graphical greeter.

I have tried each of the graphical greeter themes (Bluecurve, 
circles, Happy Gnome) but nothing seems to matter. I also tried to 
find where the font size is specified in gdm.conf but found nothing.

Version-Release number of selected component (if applicable):
gdm-2.4.4.5-1

How reproducible:
Always

Steps to Reproduce:
1. Bring system up to runlevel 5.
2. Set gdm local greeter to graphical greeter.

    

Actual Results:  Fonts on graphical login screen are still too tiny.

Expected Results:  Fonts should be large enough to read.

Additional info:

X display running in 16-bit mode at 1024x768 resolution. I have also 
used redhat-config-xfree86 when logged into the X console as root to 
change the resolution and bit depth to no avail. When I run redhat-
config-xfree86 from a text window then I am unable to use it because 
the fonts are too small.
Comment 1 Glen Shadbolt 2004-05-21 21:46:38 EDT
I have this problem as well. I had the problem with FC1 and I am
seeing it again with FC2. 

In the past the problem disappeared on two occasions. I usually have
an ATI Radeon 9000 graphics card installed. The problem disappeared
when I installed an nVidia graphics card, and then switched back to
the ATI card. It also disappeared when I installed the ATI drivers,
and was still gone when I switched back to the standard driver.
Whenever I do a fresh install of Fedora the problem comes back.
Comment 2 Mark McLoughlin 2004-06-04 09:37:06 EDT
Hmm, I've having a hard time understanding how the video card driver
could affect what fonts are used. Especially if it only affects the
graphical greeter.


Anything of interest in /var/log/messages or the Xserver log? Any
other font problems you've noticed with this card/driver combination?
Comment 3 Glen Shadbolt 2004-06-28 03:10:25 EDT
Created attachment 101459 [details]
"Screen" sections from xorg.conf that does not produce error.
Comment 4 Glen Shadbolt 2004-06-28 03:17:52 EDT
Created attachment 101460 [details]
Xorg log with tiny fonts.
Comment 5 Glen Shadbolt 2004-06-28 03:18:29 EDT
Created attachment 101461 [details]
Xorg log with normal fonts
Comment 6 Glen Shadbolt 2004-06-28 03:29:06 EDT
I haven't noticed any other problems with this card/driver
combination. After installing fc2 I did start to get the following
error showing up in /var/log/messages (kernel: vesafb: probe of
vesafb0 failed with error -6) but I haven't noticed any ill effects.

Recently I set up a second monitor, and while I was messing around
with Xorg.conf I accidentally fixed the problem. In the "Screen"
sections if I switched around Screen identifiers the problem went
away. Switching the Screen identifiers reliably produces or eliminates
the tiny fonts on the greeter (see the attachment above).

If you grep the two log files above for "Display" you get this from
the good one:

(II) RADEON(0): Primary Display == Type 1
(--) RADEON(0): Display dimensions: (340, 270) mm
(II) RADEON(1): Secondary Display == Type 1
(**) RADEON(1): Display dimensions: (2550, 2550) mm
(WW) RADEON(1): Probed monitor is 340x270 mm, using Displaysize
2550x2550 mm

And this from the bad one:

(**) RADEON(0): Display dimensions: (2550, 2550) mm
(WW) RADEON(0): Probed monitor is 340x270 mm, using Displaysize
2550x2550 mm
(II) RADEON(1): Secondary Display == Type 1
(--) RADEON(1): Display dimensions: (340, 270) mm
Comment 7 Ed Espino 2004-07-22 16:41:55 EDT
We ran into this issue as well.  We were able to resolve this issue by
updating the following BIOS settings for our Dell Dimension 4600
machines.  Can someone try and explain why these modifications correct
the problem.

BIOS (for Dell desktops)

* Enter the BIOS by pressing the F2 key when the Dell screen appear
during boot.
* Go to "Memory Information" and change AGP Aperture from 128 MB to 64 MB
* Go to "Integrated Devices" and change Onboard Video Buffer from 1 M
to 8 M
Comment 8 Matthias Clasen 2005-04-22 01:45:57 EDT
We fixed a dpi issue in the gdmgreeter in rawhide recently, which was probably
causing this symptom. 

Note You need to log in before you can comment on or make changes to this bug.