Bug 1148789 - pulp-admin tab completion doesn't support docker plugin
Summary: pulp-admin tab completion doesn't support docker plugin
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Pulp
Classification: Retired
Component: z_other
Version: 2.5
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 2.6.0
Assignee: Irina Gulina
QA Contact: Martin Minar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-02 11:31 UTC by Irina Gulina
Modified: 2016-07-04 00:58 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-28 22:37:17 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Pulp Redmine 557 0 None None None Never

Description Irina Gulina 2014-10-02 11:31:18 UTC
Description of problem:
pulp-admin tab completion doesn't support docker plugin

Version-Release number of selected component (if applicable):
>> rpm -qa | grep pulp-server
pulp-server-2.5.0-0.6.beta.el6.noarch

How reproducible:
always

Steps to Reproduce:
>> pulp-admin -u admin -p admin 
auth      bindings  --config  consumer  --debug   event     -h        --help    iso       orphan    puppet    repo      rpm       server    tasks  

There is no docker option, however
>> pulp-admin --map | grep docker
docker: manage docker images
    uploads: upload docker images into a repository
    sync: sync a docker repository from an upstream index
    publish: publish a docker repository
    export: export a docker repository

Expected results:
>> pulp-admin -u admin -p admin 
auth      bindings  --config  consumer  --debug   docker    event     -h        --help    iso       orphan    puppet    repo      rpm       server    tasks

Comment 1 Irina Gulina 2014-10-09 21:47:34 UTC
https://github.com/pulp/pulp/pull/1225

Comment 2 Chris Duryee 2014-11-19 23:38:01 UTC
This patch is in 2.6-dev and master. setting target version to 2.6.0.

Comment 3 Chris Duryee 2014-12-23 20:52:39 UTC
fixed in pulp 2.6.0-0.2.beta

Comment 4 Brian Bouterse 2015-02-28 22:37:17 UTC
Moved to https://pulp.plan.io/issues/557


Note You need to log in before you can comment on or make changes to this bug.