Bug 1148923 - ValueError: this device's formatting cannot be modified
Summary: ValueError: this device's formatting cannot be modified
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:82d09a1ead3b8e4dc9e251d1d8f...
: 1150043 1153530 (view as bug list)
Depends On:
Blocks: ZedoraTracker F21BetaBlocker F21BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2014-10-02 16:12 UTC by Orion Poplawski
Modified: 2014-10-20 23:02 UTC (History)
14 users (show)

Fixed In Version: anaconda-21.48.10-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-20 23:02:18 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (196.52 KB, text/plain)
2014-10-02 16:12 UTC, Orion Poplawski
no flags Details
File: anaconda.log (4.61 KB, text/plain)
2014-10-02 16:12 UTC, Orion Poplawski
no flags Details
File: environ (448 bytes, text/plain)
2014-10-02 16:12 UTC, Orion Poplawski
no flags Details
File: ks.cfg (16.31 KB, text/plain)
2014-10-02 16:12 UTC, Orion Poplawski
no flags Details
File: lsblk_output (1.25 KB, text/plain)
2014-10-02 16:12 UTC, Orion Poplawski
no flags Details
File: nmcli_dev_list (1.06 KB, text/plain)
2014-10-02 16:12 UTC, Orion Poplawski
no flags Details
File: os_info (381 bytes, text/plain)
2014-10-02 16:12 UTC, Orion Poplawski
no flags Details
File: program.log (21.68 KB, text/plain)
2014-10-02 16:12 UTC, Orion Poplawski
no flags Details
File: storage.log (43.57 KB, text/plain)
2014-10-02 16:12 UTC, Orion Poplawski
no flags Details
File: syslog (53.75 KB, text/plain)
2014-10-02 16:12 UTC, Orion Poplawski
no flags Details
File: ifcfg.log (4.23 KB, text/plain)
2014-10-02 16:12 UTC, Orion Poplawski
no flags Details
File: packaging.log (3.32 KB, text/plain)
2014-10-02 16:12 UTC, Orion Poplawski
no flags Details

Description Orion Poplawski 2014-10-02 16:12:35 UTC
Description of problem:


Version-Release number of selected component:
anaconda-22.7-1

The following was filed automatically by anaconda:
anaconda 22.7-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 608, in __init__
    raise ValueError("this device's formatting cannot be modified")
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 883, in initializeDisk
    destroy_action = ActionDestroyFormat(disk)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 847, in clearPartitions
    self.initializeDisk(disk)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 589, in execute
    storage.clearPartitions()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1932, in doKickstartStorage
    ksdata.clearpart.execute(storage, ksdata, instClass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/spokes/storage.py", line 368, in execute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/hubs/summary.py", line 62, in setup
    spoke.execute()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/__init__.py", line 171, in setup
    should_schedule = obj.setup(self.ENVIRONMENT)
  File "/sbin/anaconda", line 1203, in <module>
    anaconda._intf.setup(ksdata)
ValueError: this device's formatting cannot be modified

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   method=http://fedora.cora.nwra.com/development/rawhide/x86_64/os/ ks=http://cobbler.cora.nwra.com/cblr/svc/op/ks/system/vmrawhide ksdevice=link kssendmac lang= text 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.17.0-0.rc7.git1.1.fc22.x86_64
product:        Fedora"
release:        Cannot get release name.
type:           anaconda
version:        Fedora

Comment 1 Orion Poplawski 2014-10-02 16:12:37 UTC
Created attachment 943464 [details]
File: anaconda-tb

Comment 2 Orion Poplawski 2014-10-02 16:12:37 UTC
Created attachment 943465 [details]
File: anaconda.log

Comment 3 Orion Poplawski 2014-10-02 16:12:38 UTC
Created attachment 943466 [details]
File: environ

Comment 4 Orion Poplawski 2014-10-02 16:12:39 UTC
Created attachment 943467 [details]
File: ks.cfg

Comment 5 Orion Poplawski 2014-10-02 16:12:39 UTC
Created attachment 943468 [details]
File: lsblk_output

Comment 6 Orion Poplawski 2014-10-02 16:12:40 UTC
Created attachment 943469 [details]
File: nmcli_dev_list

Comment 7 Orion Poplawski 2014-10-02 16:12:41 UTC
Created attachment 943470 [details]
File: os_info

Comment 8 Orion Poplawski 2014-10-02 16:12:41 UTC
Created attachment 943471 [details]
File: program.log

Comment 9 Orion Poplawski 2014-10-02 16:12:42 UTC
Created attachment 943472 [details]
File: storage.log

Comment 10 Orion Poplawski 2014-10-02 16:12:43 UTC
Created attachment 943473 [details]
File: syslog

Comment 11 Orion Poplawski 2014-10-02 16:12:44 UTC
Created attachment 943474 [details]
File: ifcfg.log

Comment 12 Orion Poplawski 2014-10-02 16:12:45 UTC
Created attachment 943475 [details]
File: packaging.log

Comment 13 Vratislav Podzimek 2014-10-07 06:33:25 UTC
Please describe steps to reproduce this issue.

Comment 14 Vratislav Podzimek 2014-10-07 11:28:12 UTC
*** Bug 1150043 has been marked as a duplicate of this bug. ***

Comment 15 David Lehman 2014-10-07 15:08:35 UTC
You probably saw these are both failing trying to reinitialize zram0, which is protected. Apparently the gui code that intends to hide them isn't running during automated installations. We should consider ignoring these at the udev level, either in installer_mode or always. See blivet.udev.__is_blacklisted_blockdev. We don't import flags there yet, but it should be possible.

Comment 16 David Lehman 2014-10-07 16:42:01 UTC
If you'd like to test a fix let me know.

Comment 17 Orion Poplawski 2014-10-07 17:11:46 UTC
I'd be happy to.

Comment 18 Orion Poplawski 2014-10-09 15:35:41 UTC
Same error with 21_Beta_TC2

Comment 19 Orion Poplawski 2014-10-13 16:56:04 UTC
Same error with 21_Beta_TC3

Comment 20 Brian Lane 2014-10-13 18:31:56 UTC
This will be fixed in the next build.

Comment 21 Fedora Update System 2014-10-15 13:15:52 UTC
anaconda-21.48.10-1.fc21, pykickstart-1.99.63-2.fc21, python-blivet-0.61.5-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/pykickstart-1.99.63-2.fc21,python-blivet-0.61.5-1.fc21,anaconda-21.48.10-1.fc21

Comment 22 Adam Williamson 2014-10-15 16:40:46 UTC
Discussed at 2014-10-15 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2014-10-15/f21-blocker-review.2014-10-15-16.04.log.txt . We agreed to punt on blocker status, as we weren't sure exactly when this issue gets triggered, but it sounded at least significant enough to grant a freeze exception. That means it'll probably get in anyway, but if you want to confirm blocker status, can we please get a bit more detail about what exactly triggers this bug? pwhalen said in the meeting he'd done several non-interactive installs with Beta composes and had not hit this.

Comment 23 Fedora Update System 2014-10-16 17:18:51 UTC
Package anaconda-21.48.10-1.fc21, pykickstart-1.99.63-2.fc21, python-blivet-0.61.5-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-21.48.10-1.fc21 pykickstart-1.99.63-2.fc21 python-blivet-0.61.5-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-12944/pykickstart-1.99.63-2.fc21,python-blivet-0.61.5-1.fc21,anaconda-21.48.10-1.fc21
then log in and leave karma (feedback).

Comment 24 Brian Lane 2014-10-18 00:12:35 UTC
*** Bug 1153530 has been marked as a duplicate of this bug. ***

Comment 25 Adam Williamson 2014-10-20 16:57:27 UTC
Orion: the fix for this should be in TC4 and later, can you please test and confirm? Thanks!

Comment 26 Orion Poplawski 2014-10-20 17:14:45 UTC
yeah, looks good to me.

Comment 27 Adam Williamson 2014-10-20 18:06:14 UTC
awesome, thanks for checking.

Comment 28 Fedora Update System 2014-10-20 23:02:18 UTC
anaconda-21.48.10-1.fc21, pykickstart-1.99.63-2.fc21, python-blivet-0.61.5-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.