Bug 1148972 - libvirt <interface> fails with: failed to retrieve file descriptor for interface: Transport endpoint is not connected
Summary: libvirt <interface> fails with: failed to retrieve file descriptor for inter...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs
TreeView+ depends on / blocked
 
Reported: 2014-10-02 19:18 UTC by Richard W.M. Jones
Modified: 2014-10-10 10:20 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-10 10:20:33 UTC
Type: Bug


Attachments (Terms of Use)

Description Richard W.M. Jones 2014-10-02 19:18:03 UTC
Description of problem:

From:
https://kojipkgs.fedoraproject.org//work/tasks/8702/7748702/build.log

libguestfs: libvirt XML:\n<?xml version="1.0"?>\n<domain type="qemu" xmlns:qemu="http://libvirt.org/schemas/domain/qemu/1.0">\n  <name>guestfs-auco8tmn6tdw7qnd</name>\n  <memory unit="MiB">500</memory>\n  <currentMemory unit="MiB">500</currentMemory>\n  <vcpu>1</vcpu>\n  <clock offset="utc">\n    <timer name="rtc" tickpolicy="catchup"/>\n    <timer name="pit" tickpolicy="delay"/>\n    <timer name="hpet" present="no"/>\n  </clock>\n  <os>\n    <type>hvm</type>\n    <kernel>/builddir/build/BUILD/libguestfs-1.27.58/tmp/.guestfs-1000/appliance.d/kernel</kernel>\n    <initrd>/builddir/build/BUILD/libguestfs-1.27.58/tmp/.guestfs-1000/appliance.d/initrd</initrd>\n    <cmdline>panic=1 console=ttyS0 udevtimeout=6000 no_timer_check acpi=off printk.time=1 cgroup_disable=memory root=/dev/sdb selinux=0 guestfs_verbose=1 guestfs_network=1 TERM=vt100</cmdline>\n    <bios useserial="yes"/>\n  </os>\n  <on_reboot>destroy</on_reboot>\n  <devices>\n    <controller type="scsi" index="0" model="virtio-scsi"/>\n    <disk device="disk" type="file">\n      <source file="/builddir/build/BUILD/libguestfs-1.27.58/builder/phony-fedora.img"/>\n      <target dev="sda" bus="scsi"/>\n      <driver name="qemu" type="qcow2" cache="unsafe"/>\n      <address type="drive" controller="0" bus="0" target="0" unit="0"/>\n    </disk>\n    <disk type="file" device="disk">\n      <source file="/builddir/build/BUILD/libguestfs-1.27.58/tmp/libguestfsWFQJER/overlay1"/>\n      <target dev="sdb" bus="scsi"/>\n      <driver name="qemu" type="qcow2" cache="unsafe"/>\n      <address type="drive" controller="0" bus="0" target="1" unit="0"/>\n      <shareable/>\n    </disk>\n    <serial type="unix">\n      <source mode="connect" path="/builddir/build/BUILD/libguestfs-1.27.58/tmp/libguestfsWFQJER/console.sock"/>\n      <target port="0"/>\n    </serial>\n    <channel type="unix">\n      <source mode="connect" path="/builddir/build/BUILD/libguestfs-1.27.58/tmp/libguestfsWFQJER/guestfsd.sock"/>\n      <target type="virtio" name="org.libguestfs.channel.0"/>\n    </channel>\n    <interface type="bridge">\n      <source bridge="virbr0"/>\n      <model type="virtio"/>\n    </interface>\n  </devices>\n  <qemu:commandline>\n    <qemu:env name="TMPDIR" value="/builddir/build/BUILD/libguestfs-1.27.58/tmp"/>\n  </qemu:commandline>\n</domain>\n
[...]
libguestfs: [00178ms] launch libvirt guest
libguestfs: trace: launch = -1 (error)
virt-builder: error: libguestfs error: could not create appliance through 
libvirt.
Try running qemu directly without libvirt using this environment variable:
export LIBGUESTFS_BACKEND=direct
Original error from libvirt: failed to retrieve file descriptor for 
interface: Transport endpoint is not connected [code=38 domain=10]

Note the XML fragment we are using:

    <interface type="bridge">
      <source bridge="virbr0"/>
      <model type="virtio"/>
    </interface>

I'm prepared to believe this is some problem with the Koji
environment.  Perhaps virbr0 does not exist?

However if virbr0 does not exist then the error is a bit obscure
and should be made better.

Version-Release number of selected component (if applicable):

libvirt 1.2.8-6.fc21.x86_64

How reproducible:

100% (in Koji)

Steps to Reproduce:
1. Run a command such as:

  guestfish -a /dev/null --network run

Comment 1 Richard W.M. Jones 2014-10-02 20:16:40 UTC
IP configuration in Koji:

+ ip addr list
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 52:54:00:ac:11:d2 brd ff:ff:ff:ff:ff:ff
    inet 10.5.125.142/24 brd 10.5.125.255 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::5054:ff:feac:11d2/64 scope link 
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 52:54:00:e7:1c:ac brd ff:ff:ff:ff:ff:ff
    inet 10.5.127.176/24 brd 10.5.127.255 scope global eth1
       valid_lft forever preferred_lft forever
    inet6 fe80::5054:ff:fee7:1cac/64 scope link 
       valid_lft forever preferred_lft forever
4: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default 
    link/ether 52:54:00:cd:cd:bb brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
       valid_lft forever preferred_lft forever
5: virbr0-nic: <BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast master virbr0 state DOWN group default qlen 500
    link/ether 52:54:00:cd:cd:bb brd ff:ff:ff:ff:ff:ff
default via 10.5.125.254 dev eth0  proto static  metric 1024 
10.5.88.0/24 via 10.5.127.254 dev eth1  proto static  metric 1 
10.5.125.0/24 dev eth0  proto kernel  scope link  src 10.5.125.142 
10.5.127.0/24 dev eth1  proto kernel  scope link  src 10.5.127.176 
192.168.122.0/24 dev virbr0  proto kernel  scope link  src 192.168.122.1 
+ ip route list

Comment 2 Richard W.M. Jones 2014-10-10 10:20:33 UTC
This seems to happen because of the configuration of Koji, so closing.


Note You need to log in before you can comment on or make changes to this bug.