Bug 114906 - ccm-tools should provide a default /etc/conf/envars
ccm-tools should provide a default /etc/conf/envars
Status: CLOSED RAWHIDE
Product: Red Hat Web Application Framework
Classification: Retired
Component: installation (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Jon Orris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-04 05:36 EST by Daniel Berrange
Modified: 2007-04-18 13:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-19 13:33:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2004-02-04 05:36:19 EST
Description of problem:
The ccm-tools package should install a default set of envvars suitable
for a typical production install. Probably:

JAVA_OPTS=-Xms512m -Xmx512m

since this is suitable for all JDKs. We should also probably include
some commented out examples for other configs - such as the Sun JDK
garbage collector optimizations.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Richard Li 2004-02-04 08:42:37 EST
what happens with the above if the machine has, say, 384MB of RAM?
Comment 2 Daniel Berrange 2004-02-04 08:51:36 EST
Experiance has shown us that production servers will very quickly fall
over with OutOfMemoryExceptions if you allocate < 512m, particulary,
if  they upload even moderately sized images / files. So running on a
machine with < 1 GB of RAM is not feasible. 
Comment 3 Richard Li 2004-02-04 08:54:54 EST
Let me rephrase my question.

If I'm downloading this thing for evaluation, and I'm not running in
production, and my machine has 384MB of RAM, and I just want to click
around, will using these defaults preclude me from running at all?
Comment 4 Dennis Gregorovic 2004-02-04 12:32:14 EST
/etc/ccm/conf/envvars is part of the ccm-tools package as of 40056.

The contents are:

  ## Environment variables to be set at ccm invocation

  ## Jave Runtime Environment parameters
  # JAVA_OPTS=-Xms512m -Xmx512m

I prefer to leave the JAVA_OPTS settings commented out for the reason
that Richard Li mentioned.  Plus, production installs should refer to
the deployment guide and use JVM settings corresponding to the
individual situation.

Note You need to log in before you can comment on or make changes to this bug.